New Umbrel installation

Hello community, new user here.
I’m trying to install Umbrel following the procedure on the official website but i keep having this errors coming up(hope you can see the screenshot i uploaded)
I have tried everything from formatting the microSD and reinstall the OS to Format the SSD Drive but nothing sims to be working.
Any suggestions?

Hello. External storage fail. Change the USB3 cable or the case (usb-to-sata adapter), one or both are broken or off specifications.

Hi and thank you for replying. This seems not to be the problem. Everything is brand new and if i plug the SSD drive to the laptop everything works properly. Anyway i have tried what you suggested and nothing changed. :thinking:

Well, Its written in logs.
You likely got a defective usb cable or sata case.
Change those pieces and do a copy test to check if working:
1 - plug SSD system to a desktop or a laptop USB3 port (blue color inside conector)
2- format SSD in any file system you like
3- write a large file file to ssd (greater than 1 GB)
4- copy the written large file from SSD to itself (in same or another directory, no matter)
5- if parts are health, copy speed should be steady and in range 100 to 160MB/second
6- if not pass copy test, change cable or case and do test again to determine the issued part.
You may also have a SSD issued, but that not so common.


Thank you again. It turned out that unfortunately it’s the SSD itself. I’m going to switch it to a new one tomorrow morning. Appreciate the help :pray:

Hello again everyone,
I have bought a new SSD, new case and new cable(300$) but i still have errors during installation. Any explanation? I ha e tried to switch to the regular USB ports, reflashing umbrel on the SD card… Nothing sims to be working

Did you do spped test before install? Did it pass the speed test? What speed?

Yes, i have followed all the above suggestions. Speed test was ok around 150

Well, still the storage problem, so maybe a power supply issue.
What is your SSD exactally? What is its amperage?

It must be something else. The previous SSD was also brand new(everything is acting) the one in the picture is the latest one)

Should I try a new case? But the one i have now is also a new one and i have tried the SSD also with the previous case

Do you use a RaspPi official power supply?

Yes, I got a full package with power supply, touchscreen and sdcard

But I can try a different power supply if you think this can be the issue. I’ll try right away

I have tried a different power supply and had the same issue+ an extra error saying “lower voltage detected “

Well, if power supply is the official, I have no more ideas. Sometimes somebody tells to have problems with 2TB SSDs, I guess it´s related to power issues. If you have opportunity, try a smaller SSD (1TB).

it’s not the SSD, I have a 8TB SSD and I’m using the Canakit power supply, it’s pretty much the same as the official power supply, albeit better. The size of the SSD doesn’t matter.