Lost internet during Lightning install now it's stuck on "installing"

I thought I was pretty strong with my command line foo but I’m missing a setup file somewhere. During install I lost internet and now I’m stuck with no icon in the GUI, and “Installing” on the Lightning Node app in the App store and nothing overall happening.

I’ve tried deleting the /app-data/lightning folder
I’ve deleted the lightning references in umbrel/.env
I’ve tried to uninstall via scripts/app uninstall lightning (says not installed)
I’ve deleted all the orphan containers under docker ps -a
I’ve deleted all the lightning images under docker images

Every time I restart (./scripts/start) the lightning folder gets recreated in the umbrel/app-data folder so I know I’m missing something. What am I missing to completely remove Lightning so I can get a clean install of the app?

Try: sudo ~/umbrel/scripts/app uninstall lightning

If it returns not installed run:

sudo ~/umbrel/scripts/app install lightning

and let me know if it outputs any errors

Feel free as well to provide your full debug log

As a heads-up if you had funds there make sure you have your seed phrase ready for a recovery because upon reinstalling to return funds back onchain you’ll need to then click “Recover Your Previous Node”

also you if uninstalling that way fails you can look at the docker containers

docker container ls -a

You’ll probably have remnants that aren’t uninstalling you’ll see them not starting.

I had this issue I cant remember though if I removed them one at a time or if i had to force pruned all stopped docker containers.

Jim -

After some trial and error, errors with missing docker network (probably because I didn’t have umbrel started) and installing/cleaning a few times I know have it up and running. Thank you.

My fix at the end was fairly straight-forward:

  1. Stop Umbrel (./scripts/stop)
  2. Clean all orphan containers (docker ps -a)
  3. Restart Umbrel (./scripts/start)
  4. Manually install Lightning (./scripts/app install lightning)
1 Like

that was it orphaned containers.
something happens when a docker install fails.
remember that command itll come in handy again

1 Like