LNbits LNURLw not working

Hi, I try to generate a LNURLw to load it on a NFC tag, as far as I know only LNbits can do that. I tried in my LNbits from Umbrel using clearnet https URL and everything in LNbits work except generating a LNURLw. It’s like it fail to generate as you see a new line where should be the list of generated LNURLw but it’s empty and disapear on refresh.
If I try on lnbits.com demo server it works fine. So is it related to Umbrel? Or has Umbrel an old version of LNbits, can I manually update it?

More detail on the setup.
Umbrel Version 0.4.18
LNbits version 0.8.0
Clearnet over external network (LTE, other location, Tor,…) everything works in LNbits exept LNURLw generation.
Onion (over Tor), LNURLw generation works.

Steps I did:

  1. Open LNbits over clearnet
  2. Open an existing wallet in LNbits
  3. Add LNURLw extension
  4. Click either quick vouchers or advanced withdrawal links
  5. The new created link does not appear below (an empty line with the 3 icons links appear but the rest of the line is empty, no link work)
  6. Open LNbits over onion
  7. All the links I tried to create are then visible on the LNURLw extension page.

Are you accessing your lnbits instance from the same LAN as your node?
Use an external internet connection when you access your local lnbits instance (not using same internet connection as your node). For example a 4G mobile connection.

I had the same issue until I realized that I am in a loop.
If you can access just fine your lnbits page using the clearnet address, nothing is wrong with your lnbits or umbrel.

Here I posted on github LNbits, all the story, to be documented

Thanks @DarthCoin for the link but I don’t think I have the same issue. I tried from Tor Browser with clearnet URL and from Firefox mobile over LTE, it’s always the same issue. All other extension work fine and can generate LNURLp for example.
I commented this open issue on GitHub as it seams to be the same as mine but so far nobody commented.

Here is what happen when I try to create one link:

Then must be something wrong with lnbits version that Umbrel updated in 0.4.18
From then Lnbits did other updates, but not sure if this was fixed.

I run lnbits with umbrel but I did not update my umbrel to 0.4.18 (I am still on 0.4.14) because I update ONLY when some core or LN is updated or important apps I use are updated (RTL, TH, lnbits).
So my instance is not affected.

I will post your issue in lnbits telegram group to see what devs says about this.

Please if you can edit that issue and post more details:

  • umbrel version
  • lnbits version (see in apps store in umbrel)
  • enviornment tor or clearnet, both
  • steps you did

So devs can understand what is happening. Otherwise they can’t respond to something that do not understand.

That’s very strange, the only thing I didn’t tried yet is to access via onion (I did try Clearnet via Tor Browser), and here I see all the vouchers I did create by trying several times.
I will edit the first my post above, thanks for the support!

Edit: now I have another issue in what I try to finally achieve, write the LNURLw on a NFC tag. LNURLw are too large for my NFC tag, the link are about 200 bytes, my tags (very old back of the drawer) tags accept 168 bytes, I need to shop for new. The adventure continues.

I have the same issue with LNbits

  • Umbrel 0.4.18
  • 0.8.0
  • clearnet

LNbits writes: LNURLs need https, i am connected over https,
Snímek obrazovky 2022-06-01 v 1.12.27

Every LNURLs plugin(p, w, creating sats dice, etc.) write this. I scan LNURLs with Phoenix, BlueWallet and Wallet of Satoshi, and it writes: P - Not looks like LNURL, BW - bad response from server, WoS - LNURL processing problem

Please help lnbits isnt nice hash isnt im down the only money i had

2022-06-08 03:05 (2 days ago)


Nicehash Deposit Invoice





Payment hash:


@DarthCoin I’ll give you what you ask for out of the 400 $ please ur a god with this stuff
ill send whatever info you need
api etc… ID …Capture1