Lightning, Update Fee Policy - Update Channel Failed

trying to update the fee policy on my umbrel (latest version 0.3.10)

Fails with “Update Channel Failed - channel from self node has no policy”

No idea how to fix this. help?

No worries.

Here’s what i had to do:

Since the ‘ghost’ or ‘zombie’ channel wasn’t available in the Umbrel or RTL User Interface (it really only was showing up as an error in the Umbrel Debug - which is why i called it a ‘Zombie’) - I could not close the channel, abandon channel, etc… could not do anything about it in lncli either.

I had to remember who the channel was connected to. I then reached out to them and asked them to force close the channel on their end. Note that this didn’t give me funds back of course, but in this case in was a very small amount of sats.

Worked perfectly and within 30 mins or so, the zombie was gone from debug logs and no errors.

I was then able to Update my Fee Policies just fine.

Hardest part of all of this was just realizing what was happening since there is no indication in the UI.

I realized also that i could see the ‘Peer’ that my channel had been connected to, in the Peer list. It may be possible that i could have disconnected from the Peer there and had the same affect. I do not know if this would have worked.