Lightning node app is very slow or does not load


I’m having trouble with my lightning node app. All other apps are working fine. I keep getting a “ETIMEDOUT” error. I have one channel open, but it has been offline for a few days now. I thought maybe it was tor or my internet connection.
I am running a rhasberrypi4 with 4GB RAM and an HDD. It hovers around 80 degrees F. it says 2.3 GB of RAM used. I have tried restarting it, which usually helps for a short time, but it isn’t a lasting fix. Any help would be appreciated. I run a business and it is hard for me to do anything with lightning when I can’t access my node.

I don’t know what happened. I have been restarting it and it hasn’t been helping. Last night I tried restarting again and when I woke up this morning it works perfectly again. my cashapp lightning transactions failed, but my wallet of satoshi transaction worked fine. Not sure what that is about. Here are logs from when it didn’t work and also logs from now that it is working.
umbrel-1668780453439-debug.log (28.7 KB)
umbrel-1669042728633-debug working.log (33.1 KB)