Lightning Channel Offline - failed to fetch block hash for height 710764: block not found


i have a problem with my Umbrel Node.

The LND daemon restarts repeatedly every several minutes and the only lightning Channel i have does not get online. I looked in the Logfiles and found this:

2022-02-03 16:32:13.741 [INF] LTND: Waiting for chain backend to finish sync, start_height=721658
lnd | panic: unable to synchronize wallet to chain: failed to fetch block hash for height 710764: block not found
lnd |
lnd | goroutine 361 [running]:
lnd |*Wallet).handleChainNotifications(0x4002c87560)

As a new User i cannot attach my debug-log to this post :frowning_face:

What can i do to fix this LND issue?

Thanks in advance.

This is a link to my Logfile in my Dropbox:

Hey there, have you tried restarting yet? The only thing that I’m seeing is that you’re running out of memory due to your 2GB RAM, have you installed any additional apps recently prior to this issue occurring?

Thanks for answering!

Yes i already tried restarting. No effect.
RAM Usage is about 900B at the moment.

1,1GB free.

Installed Apps: PiHole, RPC Explorer, BlueWallet Lightning

Any Ideas for fixing it?

i have the same problem. Can anybody help?

lnd | 2022-02-16 07:35:43.353 [INF] LTND: Waiting for chain backend to finish sync, start_height=723563
lnd | panic: unable to synchronize wallet to chain: failed to fetch block hash for height 713440: blo ck not found

I changed from 2GB to 8GB Raspi 4 and synched the complete Blockchain again.

I still have the same Problem and also need help!

Did you try to re-flash the mSD card?

Yes. SD Card was reflashed.

The problem still persists.

lnd log:
livelog_lnd.txt (74.9 KB)

debug log
umbrel-1645018507412-debug.log (46.3 KB)

My umbrel shows no transactions in the bitcoin wallet. Seconds later, the transactions are displayed again. The status is constantly changing. Do you have the same issue?

@phlippie , do a reflash of SD card with last version, an also do a complete firmware and software update of RaspPi.
To check firmware version use command ‘sudo rpi-eeprom-update’ and follow the instructions to update if needed.
To check software version use command ‘sudo apt update’ , then update with ‘sudo apt full-upgrade’
Restart Umbrel after each updates.

Everything done, but the problem still exists. :cry:

Is nobody out there who has an idea to fix this?


Did you try accessing from different browser? same issue?

did you try checking what’s happening in the channel(s) from or similars?

If all the above did not change anything or provide any insight, did you have a channel backup?

I used my channel Backup. All Channels are closed or closing. I did this with Blixt App.
At the moment i only have a fraction of my bitcoins back. Now I have to wait…


Can you report here if the restore was successful ?


If you already closed the channels and recover funds in Blixt, do not start again your Umbrel with the same seed.
Start from scratch with new instance, new nodeID, all fresh.
Be sure you do not have hardware failures.

1 Like

Current status after 23 hours:
I forgot to enable tor.
Nearly all channels closed. A few are closing. Zero Bitcoin recovered. :frowning:
I have to wait and will report.

In the meantime I had received sats back. But now i have a zero balance. Is that normal?

The onchain wallet is not shown on the main screen of Blixt. Go to top left drawer and select onchain. There you will see the onchain txs.
Main screen is only for LN.
You can just use Blixt with those funds as a companion of your new Umbrel node.
Check this special guide that explain why: