Invidious without Umbrel login and clear net URL

Hello Umbrel community,
I was very positively surprised to see Invidious and Nitter in the Umbrel app store. I immediatly tried Invidious and it’s amazing. I first run it from a local IP and didn’t notice but later I figure out that I need to pass the Umbrel login to access it, it’s kind of stupid in my opinion. Mempool, LNbits, BTCPay and many other app doesn’t need Umbrel login to run.
On top of that I did a reverse proxy (like I did for other app) to access the app from clear net but then I guess I’m blocked because of the Umbrel login. It redirect me to https://invidious.mydomain.tld:2000/?origin=host&app=invidious&path=%2F the same way it’s redirecting to http://local_umbrel_IP:2000/?origin=host&app=invidious&path=%2F when I try to access without being login to Umbrel.
How can I skip that?

Hi, here’s some documentation on how to disable umbrel authentication.

Basically you just need to modify the docker-compose.yml and add PROXY_AUTH_ADD: "false" in the environment variables.

Thanks for the link and hint. But I didn’t find the right docker-compose.yml file I guess. Obviously I don’t want to disable it for all apps, only for Invidious. On the GitHub page there seams to be a whitelist system but again I cannot figure it out where it must be.

It’s located in home directory for umbrel user.
Folder ~/umbrel/app-data//docker-compose.yml

But I still didn’t get, how to trigger this file.
Restart umbrel or build docker image.

I had to edit docker-compose.yml in:

changing services section as:

      APP_HOST: invidious_web_1
      APP_PORT: 3000
      PROXY_AUTH_ADD: "false"

And reinstalled invidious

1 Like

Sorry I didn’t took time to try but I confirm it works now, after adding the parameter + reinstalll of the app (I missed your last line and was wondering what’s still wrong).

By the way, it’s the same for Nitter if other need it too.

Thanks for help.

1 Like