How to install Home assistant supervised on umbrel?


I´ve installed Home assistant on umbrel but some of my integrations needs to be installed with supervised mode. Could anybody help me with it?

There is some ideas in this link but I don´t know how can I access to my umbrel with a terminal console…



Need help with this for sure. Please!!!

The steps where as follows:

Connect to you Raspi via ssh:

ssh umbrel@umbrel.local


ssh umbrel@ip-address-of-your-raspi

in case the hostname doesn’t work in your network. Password should be the same as for your umbrel login.

Update your OS with the following two commands:

sudo apt-get update
sudo apt-get upgrade

Install the needed Home Assistant Supervised dependencies:

sudo apt-get install network-manager apparmor-utils systemd-journal-remote udisks2 jq -y


sudo reboot now

You will lose your ssh connection, so wait a couple seconds and reconnect to your Raspi.

Next, get the Agent for Home Assistant OS (check the github, if there is a newer version than 1.4.1):


and install it:

sudo dpkg -i os-agent_1.4.1_linux_aarch64.deb 

Now you should be ready, so get the official Home Assistant Supervised installer script:


Install the package

sudo dpkg -i homeassistant-supervised.deb

You will see a dialog asking you to select machine type. Choose raspberry4-64

The first start of HASS supervised will take some time. After a minute or even 5 minutes (be patient here) you can open a new tab and type your device IP on port 8123 (default Home Assistant port). Example: http://umbrel.local:8123

If there’s anything broken, try:

sudo dpkg –configure -a
sudo apt –fix-broken install
1 Like

Thanks for the nice tutorial!

When running:

sudo dpkg -i os-agent_1.4.1_linux_aarch64.deb

I get error:

umbrel@umbrel*:~ $ sudo dpkg -i os-agent_1.4.1_linux_aarch64.deb

(Reading database … 40820 files and directories currently installed.)

Preparing to unpack os-agent_1.4.1_linux_aarch64.deb …

Unpacking os-agent (1.4.1) over (1.4.1) …

dpkg: dependency problems prevent configuration of os-agent:

os-agent depends on udisks2; however:

Package udisks2 is not installed.

dpkg: error processing package os-agent (–install):

dependency problems - leaving unconfigured

Processing triggers for dbus (1.12.20-0+deb10u1) …

Errors were encountered while processing:


Any tips?

So I found out the issue, just not how to fix it.

umbrel@umbrel:~ $ sudo apt install libglib2.0-bin
[sudo] password for umbrel: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libglib2.0-bin is already the newest version (2.58.3-2+deb10u4).
libglib2.0-bin set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 homeassistant-supervised : Depends: network-manager but it is not going to be installed
                            Depends: apparmor but it is not going to be installed
                            Depends: systemd-journal-remote
 os-agent : Depends: udisks2
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I ran into the same issue when doing this. According to my history I just had to install the correct udisks2 package and fix the installation

sudo apt update
sudo apt install udisks2
apt --fix-broken install

Maybe this should be added to the tutorial. Hope it helps.

I´m also using Pihole and since i installed Home-Assistant without issues on other apps etc. Pihole isn´t able to start anymore:

Starting app pi-hole…
Removing pi-hole_server_1
Recreating 9cadcec9ab7a_pi-hole_server_1 …
pi-hole_tor_server_1 is up-to-date
pi-hole_app_proxy_1 is up-to-date
Host is already in use by another container
Recreating 9cadcec9ab7a_pi-hole_server_1 … error

ERROR: for 9cadcec9ab7a_pi-hole_server_1 Cannot start service server: driver failed programming external connectivity on endpoint pi-hole_server_1 (c33bd021ae52324606c7f4a967d66a91e92d9065b64e6b68eb410816a8cafc38): Error starting userland proxy: listen udp4 bind: address already in use

ERROR: for server Cannot start service server: driver failed programming external connectivity on endpoint pi-hole_server_1 (c33bd021ae52324606c7f4a967d66a91e92d9065b64e6b68eb410816a8cafc38): Error starting userland proxy: listen udp4 bind: address already in use
Encountered errors while bringing up the project.
Got signal: debug
karen is getting triggered!

sudo netstat -tunlp | grep 53
tcp 0 0* LISTEN 319/systemd-resolve

Do we need this for Home Assistant, or can we change that?

Works pretty well! Unfortunatly I see some HA Repairs.

1. System is unsupported because AppArmor is working incorrectly and add-ons are running in an unprotected and insecure way.
I cannot seem to find a way to add a flag to the kernel

2. System is unsupported because Systemd Journal and/or the gateway service is missing, inactive or misconfigured . The systemd service is running.

3. System is unsupported because the operating system in use is not tested or maintained for use with Supervisor. Not fixable withing umbrel I would say

4. System is unsupported because additional software outside the Home Assistant ecosystem has been detected. Idem.

The first 2 issues seem solvable. But how? :smiley:

Hi, I followed the instructions here and ignored all the suggested repairs.
I am trying now to add a CC2531 but HA does not see it at all, do you think it is because of the hacked supervised install?

Thx for your work !

How uninstall properly ?
Thx a lot !

when i ran

it error pls help me

[error] Debian GNU/Linux 10 (buster) is not supported!
dpkg: error processing archive homeassistant-supervised.deb (–install):
new homeassistant-supervised package pre-installation script subprocess returned error exit status 1
[info] Undo divert on abort-install
No diversion ‘diversion of /etc/NetworkManager/NetworkManager.conf to /etc/NetworkManager/NetworkManager.conf.real by homeassistant-supervised’, none removed.
No diversion ‘diversion of /etc/NetworkManager/system-connections/default to /etc/NetworkManager/system-connections/default.real by homeassistant-supervised’, none removed.
No diversion ‘diversion of /etc/docker/daemon.json to /etc/docker/daemon.json.real by homeassistant-supervised’, none removed.
No diversion ‘diversion of /etc/network/interfaces to /etc/network/interfaces.real by homeassistant-supervised’, none removed.
[info] Resetting debconf selections
[info] Removal complete, due to the complexity of this installation method,
[info] you will need to manually remove the containers created by the supervisor
Errors were encountered while processing:

1 Like

Same happens to me. Have you found out how to solve this?

1 Like

I found a way to fix it! You have to change BYPASS_OS_CHECK=${BYPASS_OS_CHECK:-false} in preinst to true.

You also have to use older version, because latest uses systemd-resolved which is supported only by Debian 12 (UmbrelOS is 10)

1 Like

Where do you change this to true?

When you have downloaded the main installer for ha create a blank folder and move the installer to that folder. Then in a command window go to that folder.

next enter:
mkdir tmp
dpkg-deb -R homeassistant-supervised.deb tmp
“edit DEBIAN/preinst and change the following line”
BYPASS_OS_CHECK=${BYPASS_OS_CHECK:-false} (that is the old line)
BYPASS_OS_CHECK=${BYPASS_OS_CHECK:-true} (that is the new line)
save the file and exit
from the root of the folder we created at the beginning enter
dpkg-deb -b tmp fixed.deb
then install thee fixed package using dpkg.

1 Like

Thanks, i’m going to give a try to this as it looks complicated to me, noobs here

1 Like

Is there any updates to getting HA supervisor on Umbrel
to make last step less complicated