How to get Lightning TLS Cert (Hex String)?

Hello, I try to connect my Umbrel node to Impervious Browser and I need a TLS Cert of my node, where can I get it in Umbrel?

1 Like

Try: :~/umbrel/app-data/lightning/data/lnd you should have a tls.cert file in this directory


Thanks, no I have to figure out how to convert it to an Hex String, what I did is not working.

I found the answer somewhere else, here is how to get the hex string of the tls.cert:
xxd -p -c2000 ~/umbrel/app-data/lightning/data/lnd/tls.cert

1 Like

I got the hex but Impervious doesn’t want to connect to my node. I tried troubleshooting it for a while and tried to do it local with no success. Each time Impervious starts locking me out after a few seconds after logging in and I have to delete all the config files to start over.

Have you (or anyone) been able to successfully connect their Umbrel node?

1 Like

Same for me, impossible to make the lightning functions work, with my node or not. It’s really confusing. Let’s wait that it get improved

Ok, here is how I did it:

With the very newest Umbrel, find the cert in this folder:

Then use a online Pem-2-Hex converter to get your Hex. Copy entire contents of your .pem file for the conversion.

It should work at that point.

Same problem here. By looking into Impervious’ log, I get the following error message:

transport: authentication handshake failed: x509: certificate is valid for, ::1,, not

Sent that in the troubleshooting channel @ Impervious Discord server, and their answer was:

The SNI of a TLS cert is pinned to a specific IP. So you have to make sure that all lines up.

I don’t know what that means, unfortunately.

Since this thread has been marked as solved, I have opened a new one:

@Eluc I’ve found the solution for the connectivity issue, and now impervious is connected to my node. The solution is documented in that thread.

1 Like