Had to use Recovery Seed, but Wallet is not syncing

Hello helpful Folks,

I run Umbrel in a Debian Virtual Machine. It worked perfectly finde up until 2 weeks ago, and i could not boot that debian anymore. So i thought i just set up a fresh Debian Container and install umbrel with the recovery seed words.

It took some time to sync the Blockchain again, which worked, but now both the wallet and my Channels are not syncing / available. It has been 24h since the Blockchain fully synced.

I still have my channels-Backup-File. Any Idea how to get the Wallet/Channels syncing and going?
Thank you very much for your kind help.

Debug Pastebin: umbrelsync - Pastebin.com


Check here: Frequently Asked Questions (FAQs)
Recovering from a channels.backup (Umbrel OS)

Report back if it worked!

1 Like

I am on it. At the moment, the command can’t find Docker, but it is running.

Update: Command went through after i did it with sudo. (“cd ~/ && sudo ./bin/lncli restorebackup…”) I am now waiting for some magic to happen :slight_smile:

I waited 10 minutes since that command. Nothing changed in the Dashboard. It is still not syncing the Wallet nor showing or closing the Channels.

My logfile: ====================== Umbrel debug info ======================Umbrel ve - Pastebin.com

Any Ideas? Thank you very much! I checked the Seedwords in Bluewallet, and the Wallet is accessible, but the sats sent to the channels are still locked in the channels.

I now reset the umbrel via
sudo scripts/stop && sudo rm -rf lnd/!(lnd.conf) && sudo rm db/user.json && sudo scripts/start which i found mentioned in another thread. This worked to make my wallet accessible again.

But the channels still do not show up. I have the feeling that my channels-backup file may be corrupted. i read that there is a backup done by umbrel itself in the cloud. how can i recover that one?


Thank you for answering. That is interesting.

I did not get the funds back. They didn’t show up in my wallet. Is there another step to do to get the funds back? I can see both withdrawals for the channels in my wallet, but no refund.


So if anyone who stumbles over this post has an idea on how to recover the funds locked in your channels after a backup - please post. and if it is true that they are unrecoverable despite the backup seed, please tell us also.

Do you have the channels.backup file? Have you followed the instructions for ‘Recovering from a channels.backup (Umbrel OS)’?

Please let us know your progress!

I have a channels-backup file and tried to recover it (see here: Had to use Recovery Seed, but Wallet is not syncing ) but it did not work. the command runs through but nothing happens.

I am not sure if my channels-backup file may be corrupt but i would expect an error message from umbrel if it is. But anyway, i did not have any luck in recovering my funds with this.

Any Ideas on this? Thank you!

That’s really concerning. If you know the other parties you were connected to, you can ask them to close the channel. Otherwise most people will close the channels because you’re offline anyway. Thus, you will get back the funds to your bitcoin wallet sooner or later.

The only risk here is that somebody may close the channel with a transaction that is not the latest state to benefit themselves and cheat you. But it’s a risk because you may send a punishing transaction. They don’t know you’re not in control of your channels.

How can i access the channels backup that supposedly umbrel keeps in the cloud (i read something about it) to be sure i tried it with the latest version? Thanks!

You must be referring to this. Would be good to know how to access it.

1 Like

It’s currently a manual process. You have to contact the Umbrel team to retrieve it. Best to keep your own backups.

1 Like


A little different than the promise on the Frontpage, but i will try to contact someone from the Team. Thanks for the clarification.

1 Like

Let us know how it goes…

Question: After restoring an Umbrel with the seed, it would take until the node is synced to the block my node starting making transactions before my wallet begins restoring? Correct?

Hi Guys - it’s solved. Channels are closed and Funds are returned.

My main Error was that i forgot that Umbrel is running inside of Docker. I copied my channel.backup to my home-dir and tried to reference it there with a "./bin/lncli restorechanbackup --multi_file /home/user/Downloads ..." command. This throws no error but simply does not work.

So if you have an up to date channel.backup file, copy it to your /lnd/ directory which is inside the docker container. then run

cd $wherever_you_installed_umbrel
docker-compose exec lnd lncli restorechanbackup --multi_file /data/.lnd/channel.backup

as mentioned in this Post: Help Recovering Lightning Channel (Linux)

If you do not have the latest channel.backup File, you can contact someone of the Umbrel Team in Telegram and ask for help. Thank you @lukechilds for walking me through. He said that in the future, the Channel Backup File will be recovered automagically in the Restore-from-Seedwords-Process.


Thanks for sharing this! Glad you resolved it. :+1:

1 Like

After running the command, how long did it take before you a change in your channels/funds?


I saw my Channels closing in the list 20-30 seconds after the command. Until the refunds were made and arrived in my Wallet i think it took around 10 Minutes