[Fixed] Failed install on Ubuntu 22.04

Hi, I attempted an install using the command curl -L https://umbrel.sh | bash. The install errored out with the message:

Starting Docker services...

Traceback (most recent call last):
  File "/usr/local/bin/docker-compose", line 8, in <module>
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/main.py", line 81, in main
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/main.py", line 200, in perform_command
    project = project_from_options('.', options)
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/command.py", line 60, in project_from_options
    return get_project(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/command.py", line 152, in get_project
    client = get_client(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/docker_client.py", line 41, in get_client
    client = docker_client(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/docker_client.py", line 124, in docker_client
    kwargs = kwargs_from_env(environment=environment, ssl_version=tls_version)
TypeError: kwargs_from_env() got an unexpected keyword argument 'ssl_version'
Failed to start containers
Skipping status update when not on Umbrel OS

I also tried to disable the docker install by executing curl -L https://umbrel.sh | bash -s -- --no-install-docker --no-install-compose but that got the same error so it looks like it’s still trying to install using the docker containers.

1 Like

That’s because the install script is pushing/installing an obsolete version of docker-compose and the system gets confused because docker ships with an updated version of it by default
I was able to fix it from my side by doing

pip remove docker-compose 
apt reinstall docker-compose-plugin
curl -L https://umbrel.sh | bash -s -- --no-install-docker --no-install-compose
1 Like

Thanks, that did work!

I’m having the same error here, I can’t solve it. I used the tip to uninstall docker-compose but it gives an error saying that I need to install docker-compose…

I removed docker-compose and reinstalled docker-compose - plugin but it says it’s already there.

I’m lost…

Try this:

The way that I has sucess was to do a clean reinstall of ubuntu and after that I installed the docker-compose first and after the umbrelOS:

sudo apt install docker-compose
curl -L https://umbrel.sh | bash -S – --no-install-docker --no-install-compose

If someone still getting this error, try this way.

what version of docker-compose do you have installed?

Another question: after reinstalling Ubuntu, did you update the packages?

Sorry for the delay. You already install the umbrel sucefully?

I just used this command to install the docker-compose, i do not choose any version, but the version installed is the 24.0.5.

After reinstalling ubuntu I ran the automatic update, after that i installed curl, docker-compose and the umbrel.

1 Like

First install docker compose
After install umbrel --no-install --docker --no-install-compose