Files App "403 Error"

I just installed a fresh install of ubuntu 18.04.6 to install the latest version of umbrel 0.5.3. I already run an umbrel on a rpi4 but wanted to set up a separate umbrel just for jellyfin since my rpi4 was limited on space and gave me some performance issues. Anyway I installed “Files” and “Jellyfin” and jellyfin created a “downloads” folder in Files. My problem is I need to put my media in that downloads for jellyfin to read it but for some reason creating a new folder or uploading a file inside of “downloads” gives a “403 Error”. I only get this error when trying to interact within the “downloads” folder. I went digging through the umbrel files on ubuntu and I think its a permissions issue. Which is strange because I Installed files & jellyfin on my rpi4 and had no such issues with the downloads folder & jellyfin just kinda worked without problems on rpi4. Hope someone can help me out. Thanks

1 Like

I’ve been trying for a day and have come up with a possible solution.

Apparently it was a permissions problem, what I did was to change the owner of the ‘downloads’ folder, from root to jpz (my user is ‘jpz’).

Enter a terminal and execute:
sudo chown -R jpz /home/jpz/umbrel/data/storage/downloads

If you installed umbrel as root user probably the directory is:
/root/umbrel/data/storage/downloads

I hope it works for you.

2 Likes

Thanks! also that command worked on my permission errors when setting up umbel “file browser” app from the store.
and also when trying to setup jellyfin media server…

so thanks a bunch!!!
M

Muito obrigado, depois de um mês, você me salvou!

O comando que eu usei: sudo chown -R umbrel /home/umbrel/umbrel/data/storage/downloads