Fatal LevelDB error: Corruption: checksum mismatch

Hi everyone,

I’m writing because I have tried pretty much everything I read around here and it and I really don’t know how to move forward.

My setup:

  • Raspberry Pi 4, all hardware according to recommendation
  • Umbrel 0.5.1-build-7ab0914

How did the problem start:

Sad to say but it was self-inflicted. I wanted to connect my node to an uninterrupted power supply in order to protect it from electricity outages, of course this lead to problems with current supply and the node did not work properly, so I reverted to the official power supply and it has been plugged there since then.

What happened:

After restarting the node I saw that my lightning and bitcoin balances were not showing, and the logs were giving the “wallet locked, unlock it to enable full RPC access” error, so I have been working on the LND part of the issue so far.

I tried (without success)

  • Deleting lnd.conf and restarting again, didn’t help
  • reinstalling umbrel via udo ./scripts/update/update --repo getumbrel/umbrel#v0.5.0
  • reflashing the SD card

Nothing has helped so far. Now I have noticed that the bitcoin app is continuously restarting so I have checked those logs and found that approximately every 45 seconds this error appears:

bitcoind_1 | ************************
bitcoind_1 | EXCEPTION: 15dbwrapper_error
bitcoind_1 | Fatal LevelDB error: Corruption: checksum mismatch: /data/.bitcoin/indexes/txindex/1374225.log
bitcoind_1 | bitcoin in AppInit()
bitcoind_1 |
bitcoind_1 | 2022-08-24T14:40:34Z scheduler thread exit
bitcoind_1 | 2022-08-24T14:40:35Z Shutdown: done

From what I have read that means I have corrupted data, so probably I have to reindex or wipe blocks and sync again

My question is: How do I do this without losing my funds? I do have a significant amount of channels in lightning and some more in the onchain wallet

Hope my description was sufficient, I’m humbly asking for help because I have reached the limits of my knowledge and don’t want to proceed without knowing what I’m doing.


Hey @Deivids1990!

This looks like a data corruption. I think you can delete the indexes directory so it can reindex properly.