Cors Error - Not allowed by CORS

Hello Umbrel Community,
does anyone have an idea how to fix a login issue (only existing in my local network).
The error says “Not allowed by CORS” (see screenshot).

Thank you for your help!

I also have this problem

Set a static IP for your node
Add that IP into your Mac hosts file
More details here

Login issue resolved for me after installing latest update.

Any other solutions?
I just got this error after my node worked fine for months.
My Umbrel already had a fixed IP. And I’m using a Mac to access it not windows.
However, I tried editing the host file as instructed, no change.
I’m getting the same error with Chrome and with Safari
Thank you,

later edit: oh well, this was solved after a restart. so there’s something else not the fixed IP thing

Important to setup your domain name on your system to point to your Umbrel device. In my case, I run Umbrel on a XUbuntu Lenovo m93p, and I set it up like this on my WIndows11 client machine, where I access Umbrel from: