Cannot install apps, docker images not pulled

Hi there,

Just installed Umbrel on an Ubuntu 20.04 server and I love it so far. Fantastic software and so easy to use. I have one issue so far: I cannot install any apps from the app store, the installation just hangs forever. This is the log from karen when trying to install an app:

karen is getting triggered!
./karen: line 68: /mnt/bitcoin/umbrel/events/triggers/: Is a directory
karen is getting triggered!                                                                                                                                  
This script must only be run on Umbrel OS                                                                                                                    
Got signal: app-install-btcpay-server                                                                                                                        
karen is getting triggered!                                                                                                                                  
Setting up data dir for app btcpay-server...                                                                                                                 
sending incremental file list                                                                                                                                
sent 166 bytes  received 23 bytes  378.00 bytes/sec                                                                                                          
total size is 2,526  speedup is 13.37                                                                                                                        
Pulling images for app btcpay-server...                                                                                                                      
Define and run multi-container applications with Docker.                                                                                                                                                                                                                                                                  
docker-compose [-f <arg>...] [options] [COMMAND] [ARGS...]                                                                                                   
docker-compose -h|--help                                                                                                                                                                                                                                                                                                

So it looks like something about the docker image pull for the app is failing, and instead docker just prints out the docker-compose usage help.

I have already tried stopping Umbrel, rebooting, and starting up again. No change.

Would appreciate any help :slight_smile:

Problem solved. Docker-compose version was not up to date and could not handle the usage implemented by Umbrel. All working fine with newest compose version