Bypass nginx and access Umbrel directly from pfsense HAProxy reverse proxy


Accessing via internal DNS example(dot)umbrel(dot)com the apps showing the “Starting” status although are perfectly running

Hi everyone,

I need some help with configuring my pfsense router to work with Umbrel. Here is what I have done so far:

  • I have installed Umbrel on a Debian based PC and connected it to my local network.
  • I have set up HAProxy with wildcards certificates on my pfsense router as a reverse proxy to access Umbrel from inside my network in HTTPS.
  • I have created a subdomain umbrel(dot)example(dot)com and pointed it to my router’s IP address.
  • I have configured HAProxy to forward requests to umbrel(dot)example(dot)com to the Umbrel’s IP address on port 80.

However, when I try to access umbrel(dot)example(dot)com from a browser, I can access the homepage but I get a Connection Timeout error when reaching apps installed. I suspect that the problem is caused by the nginx proxy that is installed by default on Umbrel. It seems that nginx is listening on port 80 and blocking HAProxy from reaching Umbrel internal port routing.

How can I bypass the nginx proxy and access Umbrel directly from HAProxy? Is there a way to disable nginx or change its port on Umbrel? Any help or suggestions would be greatly appreciated. Thanks in advance.

Hi @astroc

Did you get a resolution to your pfsense reverse proxy issue?

I am also setting up a pfsense firewall in front of a couple of BTC nodes and am struggling to configure the firewall rules…

Any help is appreciated :v:t2:

FN

Hi,
I did not find the solution but the issue is not caused by the firewall rules.
If you try to install a docker app (not via Umbrel) you will be able to access it via reverse proxy, zero problems.

The issue here is the nginx reverse proxy catching the web request, but I’m not an expert and I don’t know how to configure it properly.

1 Like