BtcPayServer outbound traffic blocked?

Sorry for the double post, but I might have a better chance to get some help by creating a brand new topic.

My issue was initially posted here:


  • I’m running BTCPaySever on Umbrel.

  • I’ve installed nginx to access it through reverse proxy in order to expose the API for my app server. It works like a charm. (

  • BTC Pay Server can’t communicate with the outside world.

    • When I try to check rates, no matter what price source I select, I get the following error ERR_RATE_UNAVAILABLE.
    • When I go into the “Plugin” section, I also get the `Remote plugins lookup failed.

I honestly have no idea as to how I would troubleshoot this.

I DID have pi-hole installes, but I never configured it. I have since removed it.

I’m familiar with how to configure a linux server, but I’m no expert. I assume it has something to do with the networking settings on my node. But I have NO idea where to start. Any help would be greatly appreciated! :raised_hands:

If you eliminate all possible causes, like Pi-hole and you are sure that you have a clear traffic to outside. then you should try to discuss this aspect with the guys from BTCPay server on
I don’t see how Umbrel guys can help you with a specific issue on BTCPay.

That’s the issue, I’m not sure that’s the case.

I don’t know the stack used to route the traffic to the docker images and I don’t know how to troubleshoot that part.

Is there a command I can run from inside the docker container to check that?


In fact, I’m pretty sure that’s the problem.

Here’s what happens when I ping from inside the Pi:

Everything’s good.

Now here’s what happens when I try to install net-tools inside my docker container:

It can’t reach the Debian servers.

If that helps, here’s a list of my docker containers:

So I’m pretty sure it’s safe to assume the problem is with the Pi configuration and not the BTCPayServer instance.

Is there some sort of internal firewall that I need to configure?

FYI, problem was solved after the latest Umbrel update. Either that did it or the reboot! :raised_hands: