Bitcoin Wallet Withdrawal

I am attempting to withdrawal Bitcoin to hardware wallet from Bitcoin wallet balance. I am getting the error

“Unable to send coins, reserved wallet balance invalidated”

Attempted with different amounts and different fee settings.

Any ideas on how to “validate the balance” do I have to close all my chanells to withrawal? Wondering on what is going on here. Thanks for any information or advice!


Not quite sure where you are seeing these numbers, but if you are trying to withdraw BTC that is tied up in Lightning Channels, then yes you’ll have to close the channels or maybe loop out the funds from the channels.


This issue is troubling me as well, just as the opening poster TBTC I have tried different amounts, also much smaller than my total balance and the total size of my channels. Please see the attached screenshot.

Perhaps there is something I don’t understand about the relative size of the total balance on the node, compared to the channels. If that’s the issue, then I can suggest some UX improvements to the error message.

Kind regards

Orange Sparrow

Same problem which I solved by importing seed into BlueWallet and withdraw funds away. Not sure if it was good idea. Maybe there is a reason why funds are locked in change address (CPFP??). Hope I did not broke anything for example if my node die and I will be forced to do recovery from seed and SCB. So I do not recommend this as a solution.

OK, thank you for sharing that solution. I can do that in case I want to ‘close down’ my node. For now, I want to keep it running and hope to be able to withdraw in a regular way. I can imagine the Umbrel team will fix this with another update?

Use apps connected to your node as
RTL - ride the lightning
All these have funcionalities for onchain transactions managing your funds from your node wallet.

Looks like the same issue I had. The way this eventually resolved for me is I closed a channel just a small channel that I didnt mind closing(not all my channels). I was then able to withdraw to a hardware wallet. Hope this helps and not sure what the issue is.

1 Like

I have the same issue here, what is supposed to be my on chain balance is impossible to withdraw. I’ve seen below that a solution could be to set a new wallet with the Umbrel seed , or to close a LN channel.
No better solution solution found meantime ?

Thank you !

I’m having the same issue.

I just tried to send with RTL - Ride The Lightning through their on-chain withdrawal, and I got the same issue and the same message.

This is on latest Umbrel Ver 0.4.4

Looking forward to a fix soon

@jphilips550 This is related to the latest feature-bug introduced into LND 0.13, the anchor output reserve.
I already report it here, on LND github and we hope that in the new LND 0.14 they will fix this shit.
I suggest to wait until then.

@mayank As I warned you, this anchor shitstorm is about to explode if the LND guys will not do something quick.
My node is blocked now: I can’t open channels, I can’t move funds from it.

FYI in my case I retry to withdraw later on and it worked.
Otherwise try through RTL of Thunderhub ?