Bitcoin Node screen blanks -> user not found -> docker dumps blockchain to HD from SSD

Windows 11 Pro (16 GB) plus USB3 2TB SSD / WSL2 / Ubuntu 20.04.05 / Windows Docker

For the second time with over 70% of the blockchain downloaded, my Browser screen data goes blank, the interface loses my user identity, the bitcoin_bitcoind_1 docker gets stuck on ‘restarting’, and then over 400 GB of the blockchain gets dumped on my 500 GB laptop SSD. I have attached a screenshot demonstrating this behavior.

Five days ago, this happened out of the blue and required me to reinstall from Win11 up. This morning it happened after noticing the power strip that the system was plugged into was turned off, likely due to my Pit Bull stepping on it when she mugged me last night. :slight_smile: In any case, this morning the system seemed like it recovered when it came out of sleep mode, as it began downloading the blockchain again. Then 15 minutes later, the screen goes blank, it thinks I’m a new user, and I have my second catastrophe in 5 days.

For perspective I’ve been working on this project for over a month, tweaking WSL 2 to be resilient enough to manage from such events as a power failure. I have 5 aborted blockchain download attempts, including a few using Umbrel 0.5.2. However, those failures were WSL and Docker related - I never experienced a failure at the Umbrel layer until I used 0.5.3 on these last two attempts, and I see another recent thread with similar issues with blank screens, login and passwords on 0.5.3.

I decided to check here this time before touching anything in the slim hopes of recovery. To make it more difficult, I can’t launch an Ubuntu terminal to check logs, which I find amazing that an app could cause the OS to also glitch like this, or how my password could be impacted by a borked Bitcoin core docker stuck on restarting. Per my screenshot, my Umbrel dockers are all running fine, and isn’t that where my user account and password is managed? Any advice, even how to shutdown gracefully and recoup my hard drive to avoid another Windows 11 reinstall would be greatly appreciated, as I don’t have it in me to go through this again, and I’ll just forget trying to do this for free using this extra PC.

Update 1: Here is the error I receive when attempting to launch an Ubuntu terminal. It does reference several get password user id errors - “getpwuid” which seems to be at the heart of the problem.

Update 2: I can confirm that the docker image dumped into Ubuntu. Is there any way to get the Bitcoin Node data back to the external mount?

UPDATE 3: I was able to run configure, debug, memory-monitor, and memory-usage and then started the install over a fresh docker instance. It now recognized my user id and password, and Bitcoin eventually came back up and started synching! But my local hard drive is almost completely filled, and according to Windows over 400GB being used by Ubuntu, and it looks like it continuing to fill up my local drive. Attaching logs, which don’t detect anything amiss. umbrel-1667757336086-debug.log (12.0 KB) umbrel-1667757165213-dmesg.log (50.1 KB)


Hi SatoshiJanx! :wave: When allocating can you use your USB3 2TB SSD exclusively? It would likely cause problems, currently Bitcoin core requires ~ 549.8GB of free space, with 1TB recommended. It could be an allocation setting issue? Let us know what else you’ve tried, and we can continue to troubleshoot.

1 Like

Hello usernameisJim and thanks for the response. Funny thing is that at least I thought I was using the 2TB USB3 exclusively. When everything was running smoothly the Umbrel dashboard showed that 1.1 TB was available and about 350GB was currently used. How the bitcoin data dropped from the USB3 down to my laptop hard drive via Docker is the mystery - especially as this happened to me twice in the last week.

In saving my Windows install, I finally detached the BTC core data by running “wsl -l -v” in PowerShell as admin, then “wsl --unregister Ubuntu-20.04” which finally freed up my hard drive! :slight_smile:

I reinstalled Ubuntu-20.04, successfully mounted the 2TB USB3, and just finished the SSH Cert connections, so I’m ready to install again. But I’d love to know if there is anything I can do to ensure it doesn’t go down this path a third time before I pull the trigger.

I’m actually wondering if I should install Umbrell under my mount location vs under my home user like my last two attempts???





I would install Umbrel under the mount location, there seem to be a lot of issues on setups like this otherwise. I would assume it’s some kind of dynamic/virtual disk reading error. If anyone knows the specific answer feel free to chime in! Thanks for updating us on that, let us know what ends up working. I will keep track and continue to research this and update you if I find anything else on the topic!

Many thanks usernameisJim! I will start the install from the mount now and keep everyone posted if additional issues or upon ultimate success.


1 Like

To my pure disgust, at 72% download, the docker threw an error that it needed to restart, and once again, everything from my external drive dumped to my hard drive and I’m out of space. FWIW, I tried the recommendation of installing from the mount, but it only showed 4GB of drive space available, so I installed from my home drive again, where 1.1TB of storage was available.

I’m not going through this again without knowing why this is happening and may just give up after so many aborted attempts each involving several days of downloading. I just don’t see this as stable enough to move a good amount of bitcoin onto to run a lightning node.

So at the end of the day, when I was downloading the Blockchain, even though on the Umbrel Dashboard it looks like it was installing on my 2TB external SSD, it was downloading to my 500MB hard drive…

For the benefit of others attempting a WSL 2 installation, to have the SSD both attach and mount correctly, I had to reformat the drive, which had been corrupted during the various attempts. I ran “lsblk” to find my SSD mount, which was ‘sdc’ in my case. Then I ran “mkfs -t ext4 /dev/sdc”.

The SSD then both mounted and attached correctly, so I ran “cd /mnt/wsl/PHYSICALDRIVE2” to switch to that drive.

I then discovered that permissions on the external mount needed to be changed by running “sudo chown -R “your-user-name” /mnt/wsl/PHYSICALDRIVE2” (again, your physical drive number may vary).

Finally, I noticed that only 1.1TB of my 2TB SSD was viable to Umbrel, so I followed this Microsoft guide and now Umbrel sees all 2 TB of my SSD:

I do remember that I had to use the Help command line context to get through some of Microsoft’s own examples (typical!), but it all worked out in the end.

Installed Umbrel from within the umbrel folder:
“sudo curl -L | bash -s – --install-path /mnt/wsl/PHYSICALDRIVE1/umbrel --no-install-docker --no-install-compose”

Finally, my largest earliest struggles were with Networking so that I could access Umbrel from any of my LAN devices via IP address. This ability was lost when WSL 1 users transition to WSL 2 or start with WSL 2. This very recent guide solves it all, and includes excellent examples of a clean Windows 11 WSL 2 with proper networking options:

I hope some or all of the tips I provided assist anyone else struggling with a WSL 2 implementation, because there sure aren’t many examples on Windows 11. :slight_smile: