BitBox - Specter Desktop - Multi Sig

Hi,

I am trying to connect my Bitbox02 to the Specter desktop app using my Umbrel node on Tor to set up a multi sig. Specter fails to detect my Bitbox when I choose to add a wallet or device. I am now stuck there.

Thank you,

Emerick

1 Like

Hi! I’m in the same place here with Trezor, I tried connecting it directly to the node and also to my computer (different devices, same network), but no detection whatsoever with Specter. Does anyone know how to proceed?

Thanks!

2 Likes

That’s because Specter running in web mode isn’t currently able to access your USB ports. You can work around it by either:

a) Setting up HWI Bridge (complicated)
b) Installing Specter on your computer instead of on Umbrel and connecting Specter to Umbrel’s Bitcoin Core over Tor (easier)

@louneskmt you ran through these steps recently, right? Are you able to drop some instructions here?

3 Likes

In this case, I would really appreciate some instructions for b).

Can you try installing Specter Desktop on your computer and then following the instructions in the wallet connecter in Umbrel.

1 Like

Thanks for your help! :raised_hands:t2: @lukechilds

I think I’m having the same problem.

I have Umbrel running on a server that I access from a laptop on the same network.

When I plug in the HW device into the server’s USB it is not detected.

Under “USB Devices” in Specter, I’ve tried both local & remote options, and added the server’s address to the HWI Bridge. However, when I select Remote USB connection and then “Save” settings, it reverts back to the Local option.

I feel like this is an Umbrel config issue, but could also be a hardware issue.

Any help is welcomed!

PS - I have successfully used Specter on my local laptop & connected to the node for multi-sig, but I’m trying to figure out the other use case of making Specter work with HW devices on the Umbrel Server directly.

I’m trying to figure out the other use case of making Specter work with HW devices on the Umbrel Server directly.

That’s not supported. Umbrel apps run in a secure sandbox and don’t have permission to access the devices USB ports.

thanks for confirming

I haven’t tried to run a HWI bridge as I don’t really see the advantage. You basically need to run Specter Desktop on your computer with the hwibridge option activated, and then connect it to your Umbrel app. It’s far less of a headache to just use the normal Specter Desktop instead of the Umbrel app. I think the Umbrel app should be use for read only wallets, or with PSBT (not direct signing).

Running Specter-Desktop locally and connect to BitcoinCore on your node via Tor is indeed by far the easiest method, especially now that Specter-Desktop has Tor-client built-in (i.e. one-button install through Specter).

However, I was curious to the HWI-bridge option as well and it is actually pretty easy to setup. Here are the steps (I’m on MacOS so perhaps some of the details differ for other OS’es):

When I mention ‘local Specter’ I mean Specter running on your laptop/desktop, not the Specter app running on your node, the latter acting as remote Specter

  1. Connect your local Specter to Specter running on Umbrel, by doing the following in your local Specter:

Preferences > select Yes, I run Specter remotely > in the URL field enter http://umbrel.local:25441/.

Restart specter on your local and afterwards you should see that it is connected to Bitcoin Core (through specter on your Umbrel node).

  1. On your local specter go to

settings > usb-devices and select Custom URL. In the field, enter http://localhost:25441/hwi/api/

  1. Access your device bridge settings (the link is mentioned on the usb-devices page of step 3) and assure that it contains the following domains:

http://127.0.0.1:25441/
http://umbrel.local:25441/

  1. Click on ‘Test connection’, plugin your hw-device and Specter should be able to detect your device.

FYI the above assumes connecting your hw-device to your local machine/laptop. As @lukechilds mentions, at this moment there is no way that specter running in Umbrel is able to detect usb-devices which are plugged directly in to your node. I guess technically it could be possible by passing either the --device or --device-cgroup-rule flag in the docker config for Specter, but you would need to know the device id upfront and pass it to these flags.

Man - I thought that I had this figured out finally when I found this thread. I’ve been attempting to get Specter to recognize my Trezor for about 1 month - well, I try once a week and then get too frustrated. I’ve got my local version of specter connected to the Node I’m running, but still no luck with recognizing the USB on my local Win10 machine. Any other advice?

Unfortunately I don’t have a Windows machine at hand, so unable to test/try to reproduce your issue. It depends a bit through which method you’ve installed Specter, but you need to make sure that it runs with the –hwibridge flag.
Perhaps also ask your question in the Specter telegram group.

Btw, is there a specific reason you’d like to connect through the HWI-bridge method? As mentioned in this thread, by far the easiest way is to just run Specter only locally and connect to your node through Tor.