After 5.0 update, LND.conf has been erased?

After update to Umbrel 5.0, it looks like my LND.conf file is empty? Has the location been moved?

I tired:
sudo nano ~/umbrel/lnd/lnd.conf

and received:
[ Directory '/home/umbrel/umbrel/lnd' does not exist ]

I also tried
sudo nano /umbrel/lnd/lnd.conf

and received:
[ Directory '/home/umbrel/lnd' does not exist ]

The resulting file is empty (or the system created a new one?)
Is there any way to find and/or restore the old LND.conf file?


Me things they have changed the paths. If you want to check the lnd.log you need to look in umbrel/app-data/lightning/data/lnd/logs/bitcoin/mainnet/lnd.log.

And you can search for the conf by using “find ~ -name lnd.conf”. “~” is the location of your users root dir - which is /home/umbrel.


Thank you! That worked perfectly.

Looks like LND is currently located at: /umbrel/app-data/lightning/data/lnd/lnd.conf

sudo nano ~/umbrel/app-data/lightning/data/lnd/lnd.conf
is the correct command to access LND.conf in the current location.


Hi guys,

this kind of worked for me but not really. Running the find command I got a two hits located in:

I opened the first file and made the changes I wanted (alias, add watchtower and so on) but after restarting (several times) they don’t really take effect. The second lnd.conf file is almost empty

In the location you posted @Filou I don’t find any lnd.conf file

Anybody having the same issues or with an idea how to edit the conf file as before?

1 Like

I was about to add the watchtower but when i opened the lnd.conf (located here: sudo nano ~/umbrel/app-data/lightning/data/lnd/lnd.conf) i found already there the lines


so i assume that from 0.5.0 the watchtower run by default.

in many tutorials I see different ways to restart lnd after a lnd.conf change.
Any of them works on umbrel 0.5.0
Any hint?

1 Like

Try restarting from the web interface (through settings)

1 Like

you can also try :

sudo systemctl restart lnd
cd ~/umbrel ; docker-compose restart lnd; docker-compose ps