Adding external drive using Beelink (Mini PC)?

Just installed 1.1.2 on a Beelink that has a 512GB hard drive, but can’t figure out how to add an external hard drive for more storage?

Maybe I missed a guide somewhere, but is this possible?

With my old install on the Raspberry Pi the external drive was picked up automatically, but not sure what I’m missing here.

Hello, chriskzoo!

I’m struggling to install Umbrel on a Beelink with the same specs as you mentioned. Could you share how to do it?

Sorry for not being able to answer your question, but just in case it helps: I have a Beelink Mini s12Pro and it comes with a socket for an external SATA 2.5’’ hard drive. I should receive a 2TB sdd today; if you want, I can let you know how the installation went after doing it.

Thank you in advance!

Hello! I just solved it and I’d like to share here how just in case someone is facing the same issue:

As a disclaimer: I am no developer and my knowledge is quite limited, so please forgive any inconsistencies or mistakes. I am neither a native English speaker, so please forgive again any typo’s or grammatical mistakes :slight_smile:

  1. I wanted to install Umbrel 1.1.2 OS in a Beelink Mini s12 Pro that came with Windows 11 installed.

  2. My problem was: I was following the Umbrel guide for x86 systems (here). When downloading the file .iso.xz and trying to flash it using Balena Etcher, the file was not supported or Balena Etchet didn’t work (it showed a “forbidden” icon). I also tried to use Rufus to flash the USB dirve and Rufus prompted a message saying that the file was not supported.

  3. How I solved it: I downloaded the following installer: (note that this file is a .img instead of an .iso (not sure of what does it mean, but to me it worked); I used Rufus to flash a USB drive and, when turning on the computer, it prompted out as the guide mentioned above said it should do. So I followed the steps of the guide and, after waiting way more than 5’ and rebooting the Mini PC a couple of times, it worked.

  4. Things I tried: it tried flashing the OS for a Raspberry Pi5, but the computer was doing nothing when starting it with the USB drive connected. I also tried decompresing the .xz file and got a file that was still not read by Balena but Rufus did read it, so I tried to flash the usb drive with it. At 96% it failed.

I hope it helps! And if anyone wants to contribute, correct or explain why this worked, I’m happy to learn.

All the best,