Umbrel 2.0 does not see additional drives

I installed Umbrel 2.0 on Proxmox to test the new Failsafe feature. I have the drives available in Umbrel:

umbrel@umbrel:~$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS
sda 8:0 0 32G 0 disk
sdb 8:16 0 32G 0 disk
sdc 8:32 0 32G 0 disk
├─sdc1 8:33 0 256M 0 part /run/rugix/mounts/config
├─sdc2 8:34 0 512M 0 part
├─sdc3 8:35 0 512M 0 part
├─sdc4 8:36 0 10G 0 part /run/rugix/mounts/system
├─sdc5 8:37 0 10G 0 part
└─sdc6 8:38 0 10.7G 0 part /mnt/root/var/lib/systemd/timesync
/var/lib/systemd/timesync
/mnt/root/var/log
/var/log
/var/lib/docker
/kopia
/home
/data
/run/rugix/state
/run/rugix/mounts/data
sr0 11:0 1 1024M 1 rom
zram0 254:0 0 2.9G 0 disk [SWAP]
umbrel@umbrel:~$

/dev/sda and /dev/sdb however they don’t appear in the UI:

Reconfigured VM with 2 x 64GB SATA drives and now they are visible in the UI but still can’t configure Failsafe.

I installed on a physical machine with two x 256Gb test name drives:

umbrel@umbrel


$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
sda           8:0    0 931.5G  0 disk 
zram0       254:0    0  11.6G  0 disk [SWAP]
nvme0n1     259:0    0 238.5G  0 disk 
nvme2n1     259:1    0 119.2G  0 disk 
├─nvme2n1p1 259:5    0   256M  0 part /run/rugix/mounts/config
├─nvme2n1p2 259:6    0   512M  0 part 
├─nvme2n1p3 259:7    0   512M  0 part 
├─nvme2n1p4 259:8    0    10G  0 part /run/rugix/mounts/system
├─nvme2n1p5 259:11   0    10G  0 part 
└─nvme2n1p6 259:12   0    98G  0 part /mnt/root/var/log
                                      /var/log
                                      /mnt/root/var/lib/systemd/timesync
                                      /var/lib/systemd/timesync
                                      /mnt/root/var/lib/docker
                                      /var/lib/docker
                                      /mnt/root/home
                                      /mnt/root/kopia
                                      /home
                                      /kopia
                                      /data
                                      /run/rugix/state
                                      /run/rugix/mounts/data
nvme1n1     259:9    0 238.5G  0 disk 

Still cant get Failsafe to work:

So… turns out the drives have to be completely erased (I used sgdisk --zap-all) before the setup runs.

I don’t think this is documented.