Rebuilt Umbrel on Rpi4, can't install apps. "no such host" error

Hi team, requesting some help with troubleshooting.


  • had a power outage while away, and umbrel stopped working. Tried a variety of things but couldn’t get it back up and running, so went the nuclear option of a fresh install, formatted SSD etc.
  • the new install appears to have worked fine, but I can’t install any apps.

Here’s what I’ve tried so far:

  • followed the advice for apps not installing in the troubleshooting guide, using SSH to restart scripts etc
  • Multiple restarts, reflashes of mSD, tried reformatting SSD again etc.

I am a noob, but looking at the debug logs, the obvious looking culprit are lines such as these after starting the install process:

ERROR: for tor Get “”: Get “”: dial tcp: lookup on [IP address]: no such host

Any advice?

====================== Umbrel debug info ======================Umbrel ve -

Also tried installing app from SSH rather than GUI, same result.

Hi @ChadLegspin, seems it is pulling with a link to the wrong image.
Let me know how you go after running the following scripts- this updates the repo, as well as the restart scripts you used before

sudo rm ~/umbrel/repos/https—github-com-getumbrel-umbrel-apps-git/.git/index.lock && sudo ~/umbrel/scripts/repo update && sudo ~/umbrel/scripts/stop && sudo ~/umbrel/scripts/start


sudo ~/umbrel/scripts/repo update && sudo ~/umbrel/scripts/stop && sudo ~/umbrel/scripts/start

and then try installing bitcoin again

sudo ~/umbrel/scripts/app install bitcoin

For anyone who has this same problem, it was a networking issue. My ISP started using CG-NAT, which means I didn’t have a Public Routable IP address. I got my ISP to sort it, and now things are working again.

1 Like