Pi-hole stuck on installation

I have Umbrel 0.4.1 installed at a computer running Ubuntu server 21.04. Umbrel is still syncing, currently about 40%.
I tried to install Pi-hole but it has been stuck att installation for many hours. I have tried to reboot Umbrel from the GUI but after reboot Pi-hole is still “Installning” and are stuck there for many hours.
I have tried to follow this https://telegra.ph/Umbrel-BTCLN-node—Troubleshooting-07-06#One-Umbrel-App-do-not-start-or-it-can%E2%80%99t-be-installed but it did not help.
What can I do to stop the installation? Why will Pi-hole not install?

Now the “Installing” are gone and the button “Install” is back.
When I check the app section Pi-hole is not installed.
Should I try to install it again? Why did it not install the first time?

Hi Max,

I am facing the same issue with a newever version indeed. Others apps are fine.

Did you fix this issue ?

Well, I took a Raspberry Pi Zero and installed PiHole there and run it as a dedicated PiHole. :slight_smile: