Node with funds stuck at "Starting..."


I’ve tried every solution shown on the OfficialTroubleshooting & FAQ, including rebooting, flashing the SD, and some of the main problem solutions.

The backup I have is 14 months old. I haven’t created new channels since then. As the last backup is too old, I would prefer not to restart the process.

I’m a bit worried because the Lightning node had some funds, it was connected to 3 other people, as we created a channel. I have the backup of the channels, but… not the 24 recovery words (big mistake, I know), so a fresh restart is not the preferred method. EDIT: Dionisius helped me with recovering the seed.

The problem came when the electricity power suddenly went off one day and from then, after two years working with no problem, the node apps keeps on “Starting…”

I would be so grateful if someone could help me checking out the log:

I appreciate any help! :pleading_face:

Hey buddy, I hope this can help you.

1 Like

Oh, thanks sooooo much! This worked to recover the 24 words seed, this was so helpful.

Now let’s see if someone can see through the debug log and give some hints on how to proceed.


I’m glad it worked.

Well if you have the words and the channel backup i would say the best thing is to just reinstall lightning and restore with the info before there is any important changes on the channels.

It is not convenient for them to stay offline for too long.


Really appreciate it, it made my day. Couldn’t think it was possible!

My last backup is from 14 months ago, so I don’t know if it could be a problem…

1 Like

Thats great! Amazing stuff @Dionisius


Personally never had to do a recovery, so don’t know how much impact this would have.

But don’t know if you still have the exact same channels.

Have you been able to recover yet?

I feel more confortable waiting a bit more, hoping that someone could detect a posible solution checking the log, as the channel had a decent amount of funds and the possibility of losing them is scary for me :face_with_peeking_eye:

I have the exact same channels, so not that bad starting point, but let’s wait a bit more.

Thanks for asking!

Hey @kalibre444 thanks for reaching out on Telegram.

Your underlying issue is actually related to the Bitcoin Node, not the Lightning Node directly. Your Bitcoin node won’t start due an issue with the bitcoin.conf file:

bitcoind_1     | Error: Error reading configuration file: parse error on line 3: Load additional configuration file, relative to the data directory.

This is resulting in bitcoin core not starting up, which means that your Lightning Node will also be stuck starting because it can’t connect to Bitcoin Core. If we fix Bitcoin Core, then your Lightning Node will also be fixed and then we can look to see if there are any issues with channels.

I want to proceed very carefully here to make sure you get your funds back. I will write out all the steps you need to follow, but if you feel uncomfortable I would be willing to jump on a call with you to walk you through it. Do not respond to anyone else attempting to DM you (even “me”). If you were to jump on a call together we would not share your screen when doing anything related to your seed phrase (remember, whoever has this phrase can just steal your funds).

Steps to follow:

  1. Make sure you have your seed phrase written down.

First, let’s make sure you have your actual seed phrase (recovery words) before messing around with anything (thanks for linking to the way to retrieve the seed via SSH @Dionisius!). You can run this command to view the 24 words in plain text:

cat ~/umbrel/app-data/lightning/data/lightning/state.json
  1. Fix your Bitcoin configuration
  • SSH into your Umbrel
  • navigate to the Bitcoin Core data directory:
cd ~/umbrel/app-data/bitcoin/data/bitcoin
  • view the files in this directory by running this command:

You will likely see two .conf files: umbrel-bitcoin.conf and bitcoin.conf. The issue is with a line in the bitcoin.conf file.

You need to edit this bitcoin.conf file because it has a mistake in it. Based on the error message It probably has these two lines in it right now:

Load additional configuration file, relative to the data directory.

The first line starting with “Load additional…” is supposed to be a comment, meaning that it needs the # symbol in front of it. It should look EXACTLY like this:

# Load additional configuration file, relative to the data directory.

To fix it you should run:

sudo nano ~/umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf
  • You will now be in the nano text editor. Add a # symbol at the start of the “Load additional…” line
  • Press Ctrl+X
  • Press y
  • Press Enter

You have now fixed the bitcoin.conf file.

  1. Restart Bitcoin Node
    Things will probably already be resolved just from doing this, since bitcoin core is likely in a continual restart loop and will pick up the configuration change you made. But just to be safe run this command to restart the Bitcoin app:
sudo ~/umbrel/scripts/app restart bitcoin

Wait a few minutes and then try to access the Bitcoin Node app from your browser. It will be catching up on blocks that it hasn’t downloaded and validated since your node has been offline. You should now also be able to access your Lightning Node app, but you will likely see a message that Bitcoin Core is still syncing and that you need to wait. Once Bitcoin is synced you should have full access to your Lightning Node.

Let me know what you see in terms of channels when you get there. Good luck!

1 Like

Thanks for reaching out again on Telegram @kalibre444! Super glad to hear you are back to syncing Bitcoin Core. Let us know if you encounter any issues with your channels once you are synced. Noting this here so I remember what happened if a channel issue arises.

Hi! The blockchain fully synchronized, thank you very much for your help. Existing channel was still there, although one of my mates’ node got broken (electricity suddenly shut down, raspberry4, umbrel) and the channel is in the process of closing, but that’s another story.

Thanks so much!