Nextcloud broke after 25.0.1 upgrade

I just upgraded my Umbrel running on RPi4 from 0.5.1 to 0.5.3. Then I upgraded Nextcloud to 25.0.1. Now it doesn’t work. When I go to the Nextcloud page, I get:

I> nternal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

I see that the log file is supposed to be at /var/log/nextcloud.log, but that file does not exist. After a search, I have found one at /home/umbrel/umbrel/app-data/nextcloud/data/nextcloud/data/nextcloud.log. The last modification time, however, was 13 hours ago, and I just did the upgrade about 1 hour ago. The log message therefore likely is not helpful (nor is it understandable!)

A “docker ps” reveals a couple funny things. First, there are two containers mapped to port 80. That seems like trouble. And the containers that are listed as running have 23.0.11 in the name.

eb6702c61894   nextcloud:23.0.11-apache            "/ apac…"   16 minutes ago   Up 16 minutes                  80/tcp                                                                                                                                nextcloud_web_1
26d63d0aa28d   nextcloud:23.0.11-apache            "/"               16 minutes ago   Up 16 minutes                  80/tcp                                                                                                                                nextcloud_cron_1

I don’t know if these are mistakes or not. “docker images” shows two images that were created 5 weeks ago:
nextcloud 4a5c95a5256a 5 weeks ago 947MB
nextcloud 0a445cea8ea5 5 weeks ago 914MB

I’ve rebooted Umbrel a couple times and I cannot get NextCloud to work. Any ideas?

I have exactly the same issue after upgrading. Did you find any solution yet?


I am experiencing the same issue.I read in another thread that Nexcloud install may have been corrupted and they had to reinstall the update through terminal on IOS. I have not found a thread that explains how to do this though. Please keep this thread updated if anyone finds a solution.

Hey, are you talking about this one?

But the cli upgrade process for our setup with docker is somehow different…hope we find a solution

1 Like


Yeah, that article references /var/www/nextcloud and /usr/share/nginx/nextcloud, neither of which exist on my umbrel. Using “docker inspect” I can see this about the container that (I think) is the main container:

        "Volumes": {
            "/var/www/html": {}

I don’t know what that means, and now I have to go to bed!

Does anyone has a solution for it?

Not yet…and I can’t find any documentation for how NextCloud is deployed and configured on Umbrel. For example, the post I made above…the /var/www/html dir inside the container is being mapped to somewhere, but where is “{}”? Clearly it’s some substitution parameter, but where does it get filled in? Why wouldn’t “docker inspect” know the value? Without knowing how the thing is supposed to be set up, it’s so hard to debug.

I’m currently looking for a freelancer to help fix this problem. If I find a solution, I’ll post it here.

Thank you… Umbrel should force a fix… cannot acces my whole Data… :frowning:

I tried stopping the docker container labelled “nextcloud_cron_1” because it is mapped to port 80 just like the “nextcloud_web_1” container, but I got the same error.

I ran docker inspect again and found some more clues.

        "Binds": [

That’s where the web directory of the nextcloud_web_1 container is mapped to. Ports are mapped as

        "Ports": {
            "80/tcp": null

I wonder if that’s the problem? Shouldn’t it be mapped to 8081?

I think this whole thing is brought up by docker-compose. Has anyone been able to find where the docker-compose file is?

I’d say port 80 is a port internal in the docker compose network

I’ll do a backup of the data and then remove nextcloud through the UI. Going forward, I won’t use nextcloud through umbrel anymore, looks like they messed up here.

And there is an open bug on Github

I got the same issue, same config : Raspberry pi 4 8GB RAM with umbrel 0.5.3 and Nextcloud 22 to Nextcloud 25.
I tried to restart docker containers used by umbrel, without success
I guess (and I hope) we need to wait for a hotfix …

I’m going to wait a few more days, but I think the nuclear option is to uninstall NextCloud from the Umbrel UI, then reinstall it. If anyone tries that let us know!

But if you do that you are obliged to save all your data before because the uninstall of Nextcloud will erase all the files right ?