Mempool app not usable anymore

It looks like bitcoin is fully synced and electrs too, but at some point, you have this error:

[2022-09-28T14:05:10.612Z WARN electrs::mempool] mempool sync failed: failed to get mempool txids

Is the Electrs app UI showing synchronized? Is it only the mempool app that is having issues?
In that case could you provide also the mempool app logs ?
sudo ~/umbrel/scripts/app compose mempool logs --tail=100

Electrs app UI shows fully synchronized. So far only mempool is giving the issue.

Here is the mempool log:

Off topic comment: The mempool website includes now insightful information on lightning network. It would be interesting to have it in umbrel’s own mempool app.


I never modified anything beyond using the UI since I last set It up from scratch.

@J0nsan have you suffered power outage at any point?

Based on this error from electrs:

electrs_1     | [2022-09-20T15:01:11.007Z INFO  electrs::daemon] waiting for RPC warmup: Starting network threads…
electrs_1     | [2022-09-20T15:01:19.061Z INFO  electrs::index] indexing 2000 blocks: [313001..315000]
electrs_1     | [2022-09-20T15:01:19.580Z INFO  electrs::db] closing DB at /data/db/bitcoin
electrs_1     | Error: electrs failed
electrs_1     |
electrs_1     | Caused by:
electrs_1     |     0: sync failed
electrs_1     |     1: failed to get block 00000000000000001fdc9bcb5505b2200d1ef6d33607222f2c5003aa2a931dde
electrs_1     |     2: receiving on an empty and disconnected channel

It looks like maybe there is an issue with Bitcoin Core. electrs is requesting a block from Bitcoin Core but Bitcoin Core isn’t able to send it. This occasionally can happen if you suffer from instant power loss (power cut or unplugging the device directly from the wall) which leads to filesystem corruption in Bitcoin Core.

We can try clearing the blockchain data from Bitcoin Core and resyncing. You won’t lose any other data but your node will take a few days to resync. You might not be able to use your Lightning node during this time.

If you want to try this you can SSH into your Umbrel and run:

sudo ~/umbrel/scripts/app stop electrs && sudo ~/umbrel/scripts/app stop bitcoin && sudo rm -rf ~/umbrel/app-data/bitcoin/data/bitcoin/* ~/umbrel/app-data/electrs/data/electrs/* && sudo ~/umbrel/scripts/app start bitcoin && sudo ~/umbrel/scripts/app start electrs

Not that I know of.

Well I guess IBD for the 4th time now it is :smiley:
(Just to be clear, I am very thankfull for the support you are giving and for umbrel itself, but I seem to be very unlucky when it comes to problems with the node that require an IBD)

Of course, I can imagine that’s frustrating!

Why did you have to do an IBD the last three times? Could you link me to your previous issues? It’s not normal that you should have this many issues. There could potentially be an issue with your hardware.

Could you list me the full specs of all the hardware you’re using. Also can I just confirm you’re using the official Raspberry Pi power supply if you’re using a Raspberry Pi.

Hey @J0nsan, has resyncing fixed the problem for you? I’m running into the same problem and want to know if this worked out for you before I start syncing from scratch again.

@lukechilds, I’m using an official Raspberry Pi power supply, but my node did suffer a power outage a while ago. The previous time that happened I didn’t run into any problem, but that might just have been luck.

Hi @Fryheid !

Im still at it, for some reason it takes quite long. Im at 88% sinced now.

Sorry for getting back so late. To be honest I can’t remember why the IBD was necessary the first times. But I think it may not be relevant anymore anyway. This was with the frist versions of umbrel before this forum existed. The last two times: Socks5() connect to … failed: general failure - Support and Troubleshooting - Umbrel Community ( and Node unreacable after updating to V0.5 - Support and Troubleshooting - Umbrel Community ( As far as I remember both of them where solved thanks to you helping via Twitter DMs. I think I see where you are getting at tho. Do you think the problem possibly lies in the hardware/the setup? Its only the 4GB Modell. But since that seemend to be a Problem I uninstalled most apps.

Yeah memory could certainly be an issue, Mempool is quite a memory hungry app. Once you’re up and running again could you check the memory usage in the settings page of your Umbrel dashboard. That should give us an idea if it’s a memory issue.

Which other apps do you have installed?

Also could you list the full specs of all your hardware?

So IBD is done now, but the same problem persists. I can’t believe it… :sob:
Memory is at 2.7 GB/4GB. The installed apps are: Bitcoin/Lighning Node, Electrs, mempool, Lightning Terminal and Pi-hole.

The specs are: Raspberry Pi 4 Modell B, Case, SSD Enclosure, SSD (1TB)

Seems that I’ve figured out my issue with mempool. I noticed in the dev tools that mempool had difficulty connecting to websockets. Checking Tor Snowflake, it had the same issue.

I started looking around and turned out my Requestly plugin was still somehow active despite deactivating all my custom rules. After also disabling the whole group (where the individual rules were already deactivated), mempool was now able to connect to the websocket.

Good luck @J0nsan on figuring out your issue, I wish you the best!

1 Like


Chiming in here to say ive had the same issue since the last major upgrade (5.0?) tried manually updating and reverting Mempool update since before the last major upgrade. Found the same behaviour, Mempool would continue to offline/reconnecting. It would continue to open WebSocket connections. Errors in the mempool_app_proxy_1 container. “Invalid value “undefined” for header “x-forwarded-host””

1 Like


Guys as much as I love umbrel, if I cant get a solution within a few weeks I think I have to look for alternative node software. Dont get me wrong. Umbrel is an amazing project with an amazing team but aparently there is no solution for this problem and I would have to set up the node again for the 5th time now. I have no problem with providing more logs and so on, but I need something. :sob: