How to know if Tor Snowflake is working?

My Tor Snowflake used to transit lots of data through, but nothing anymore last months.
I tried reinstalling it some weeks ago, but no activity yet.
So, is there a way to test if it works? (using raspberry pi, umbrel 0.5.3, other things seem ok)


No more activity for me too, since the 23rd november. Maybe an update is necessary ?

1 Like

Mine stopped working also in that timeframe after working for months. I deleted and reinstalled a few times with no effect. Good to know it wasn’t just me, I was thinking it was a network setting I messed up or my ISP was doing something it shouldn’t.

Maybe something bad with Umbrel v0.5.x

Same here. No activity. Was hoping we just needed an update or something.

Seems like, it basically broke.

It looks like in the Umbrel app store we’re using 2.1.0 (2022-02-08), but at the git it’s like 2.4.1 (2022-12-01)?

I’ve tried all the same (uninstall, reinstall, etc), with no luck.

I did also try the SnowFlake Chrome interface (non-umbrel/non-Pi) and do get connections. This confirms it’s not a firewall or ISP related issue and seems to align with what others in this thread are experiencing.

Is there a way to update manually via SSH that’ll reflect within Umbrel or any ETA from Umbrel as to when the update will be available? It would be nice to get caught up a bit in versions (that may or may not solve this issue).

May be related to the following post?

If we’re running a version on Umbrel from early 2022 and the following post is indicating in July that an update is needed to continue working there may be issues? This could explain why I’m having more luck in Chrome (newer version) and not in Umbrel.

Chrome extension is 0.7.0 and the below post is indicating it should be at least 0.6.1 whereas the Umbrel Snowflake version is 2.1.0 and there’s been updates since ( where we’re running a version predating the post below indicating updates are needed.

Shouldn’t Umbrel be able to poll git repositories for updates so we can be more current with these things (than waiting for updates to come into the Umbrel app update list) or at least an option to do so? We’re pretty far behind on updates for this app (and likely other apps).

I believe the big issue for the fact this isn’t updated and naturally broke, is that this is not being upstreamed from the actual docker image of snowflake but from the one who made the original pull request for umbrel which has never updated it since 9 months.

1 Like

What’s the best method to get this resolved?

Seems like only Twitter is used by Umbrel and the devs are barely interacting with their own forums.

Is this dying project and best to look for alternatives for long-term reliability?

I see this group of messages in snowflake.log, once a day:

2022/12/14 12:50:45 WebRTC: Created offer
2022/12/14 12:50:45 WebRTC: Set local description
2022/12/14 12:50:45 Offer: {… info cut, it looks like lots of personal info…}
2022/12/14 12:51:11 NAT Type measurement: restricted -> restricted = restricted

then nothing else happens.
But what means that last line?

Tor Snowflake Proxy is now updated to 2.4.1 as of this morning, thank you for the feedback!

Just wanted to confirm for those in the thread that the update looks to have fixed the issue I was having and may have fix it for others also.

FYI - reinstalled Snowflake Proxy and it is passing traffic again

2022/12/27 11:41:40 In the last 1h0m0s, there were 28 connections. Traffic Relayed ↑ 203709 KB, ↓ 16078 KB.
2022/12/27 12:41:40 In the last 1h0m0s, there were 24 connections. Traffic Relayed ↑ 52314 KB, ↓ 4739 KB.