Homebrew issues

This isn’t really an umbrel issue but I was wondering if anybody had heard or seen this issue with homebrew before. I’m not very well versed in terminal. However, I have gotten homebrew and tor to work and am using electrum to connect to my node. However just recently I am getting an error when I try to start or stop tor using homebrew.

Error: Failure while executing; /bin/launchctl bootstrap gui/501 /Users/x/Library/LaunchAgents/homebrew.mxcl.tor.plist exited with 5.

I still seem to be able to connect Electrum to umbrel. But this just worries me as I can’t tell if tor can be stopped or started at this point.

Did you install Tor and Electrum via Homebrew? If so, you should use brew services to start/stop a service, not launchctl.

Output of brew info tor

To restart tor after an upgrade:
brew services restart tor
Or, if you don’t want/need a background service you can just run:

Please note that your Homebrew path might differ from mine if you have an Intel-based Mac.
Intel: /usr/local
Apple Silicon: /opt/homebrew

I installed tor via homebrew, not electrum. I was using brew services to start and stop tor. Below is what is happening:

brew services start tor
Bootstrap failed: 5: Input/output error
Error: Failure while executing; /bin/launchctl bootstrap gui/501 /Users/x/Library/LaunchAgents/homebrew.mxcl.tor.plist exited with 5.

However, after the upgrade I ran ‘brew services restart tor’. Seemed like that worked and tor is running. However, I just don’t get why I’m getting this error when trying to start and stop using ‘brew services start tor’ or ‘brew services stop tor’

After thinking about this some I see what you mean about launchctl. However, if I’m running ‘brew services start tor’ what should I do differently? Sorry, as I said I’m rather new to all of this.

I tried searching for the error message, but there seem to be a lot of different solutions.

Let’s start with step 1. Do you have an Apple Silicon Mac? If so, do you have Rosetta 2 installed?

No Apple Silicon. It’s a macbook pro 2018. As a side, I tried completely uninstalling Homebrew and reinstalling. This worked for a while and I was able to start tor again using ‘brew services star tor’. However, after the first time of using that command, it began giving the same error when I stopped tor and tried to start it again using the same command. Also, when I enter ‘brew services list’ it returns tor as open but says error under status.