Electrs Waiting for Bitcoin Node to finish syncing

Hello everyone,

I run umbrel 1.0 on my raspberry pi 5 and I installed the Electrum server application (“Electrs”).
My bitcoin node is fully synchronized but Electrs still saying me “Waiting for Bitcoin Node to finish syncing…”.

Anyone can help me on this issue?
Thank you.

Hi @Ghoost glad to hear your other issue was resolved. If you’re Bitcoin node recently finished syncing, it may take ~24hrs for Electrs to build it’s own database which should resolve this issue.

Thank you @smolgrrr I will wait to see if it is resolved.
Do you know if it possible and how to connect to a docker container since Umbrel 1.0?

Hey @Ghoost, can you please clarify how you’d like to connect to a docker container? For eg. what’s your use case?

Hi @mayank , what I mean is for connecting to the pi-hole container for example.
When I run the command docker exec -it pi-hole_server_1 bash for example it should connect me to the container with a bash, but with Umbrel 1.0 it is not working anymore (it was working with umbrel 0.5). That’s why I’m asking.

@Ghoost Interestingly, this command is working ok for me on umbrelOS 1.0:

sudo docker exec -it pi-hole_server_1 bash

Looks like it could potentially be a Docker bug: docker run with -t option lead to "open /dev/ptmx: no such file or directory" message · Issue #2067 · docker/cli · GitHub but we need to look deeper.

Ok thank you @mayank, i’m running umbrel OS 1.0.2 on my Raspberry pi5. I will try to have a look when I have more time :slight_smile:

Hello @smolgrrr, the problem fixed. I restarted my umbrel and waited a bit of time and now Electrum server is fully synchronized :slight_smile: Thank you for your help!

1 Like

I have been experiencing the same either with umbrel 0.5 and 1.1 and my ‘fix’ has always been the same: The most ridiculous and not-technical fix I have ever used: When I install the Electrs server, I have to let open that window all the time until the syncing reach 100%:

I could take about 12-20 hrs, because if I close it, and open the electrs app at a latter time it says: Waiting for the Bitcoin Node to finish syncing, even it is at 100%