Electrs - Waiting for Bitcoin Node to finish syncing

I’m running Bitcoin Node on Umbrel and have recently tried to install Electrs. The status is stuck in “Waiting for Bitcoin Node to finish syncing…” without any progress shown on the progress bar.

I have tried to type some of those commands in the Terminal on my Mac even though I didn’t really understand what they mean but it didn’t help.

I would like to connect my Bitcoin Node to my wallets (both mobile and desktop) but it looks like it’s not possible at the moment because Electrs is not finished syncing. At least the connexion with my Electrs doesn’t manage to work on Phoenix wallet.

The first download of the Bitcoin Node took me ages - like 3 months. Is this also going to be the same for Electrs?

1 Like

that is a super long time to DL the chain are you using a HDD instead of a SSD?

WIth a SSD Electrs will take about 24 hours or so.

i dont think it shows progress.

Been trying to figure out what’s going on with Electrs all day today. I had my Electrum wallet synced a few months ago and now I haven’t been able to get past “Waiting for Bitcoin Node to finish syncing.” I’ve rebooted and reflashed the OS, deleted apps, etc. Bitcoin Core is fully synced. I’ve tried reconnecting through Electrum wallet and even tried setting up Sparrow to connect…it’s a no go. Something is up.

I’ve read that you’ve got to wait 10-24 hours but I would think that would be the case if it was a full wipe. I’m no expert so i’ve been digging around like crazy. It would be great to have someone look into this issue.

If you leave it alone for about 24 hours it’ll sync but if you keep restarting it and installing and reinstalling your going to have a bad time. You need to have patients

Run the troubleshooter and if you don’t see anything there

ssh in and run

docker container ls -a

see if electrs is running properly
Youll be able to see if its just rebooting over and over or if its running

Why do i need to let Electrs sit for 24 hours with no indication of any progress? We aren’t talking Bitcoin core. If like to know some details as to what’s going on under the hood that this is a requirement. I let it sit for 4 hours with no progress. At least with core, you would have some indication of movement in process.

This would be helpful to a lot of people who are running into the same issue.

Open a new SSH window and check if there are any errors in the Compose Logs application.
Check with:
sudo ~/umbrel/scripts/app compose electrs logs --tail=600

I think I’ve figured out what my issue is. Checking the debug logs, Electrs is saying that it cannot work with a pruned Bitcoin node ledger. I changed this setting a week ago so that makes sense. I have reenabled full ledger and waiting for the sync process to complete. It’s been about 2 days so far. Anyone have any experience with resyncing after undoing a prune?

1 Like

Its going to go through the entire thing

This is fine and expected…the question I have now is how to check the status of the resync? What’s the command line through ssh to check the status? The Node app isn’t updating with its current sync progress.

for electrs? itll be done in about 24 hours

or do you mean bitcoin core?

I meant for Bitcoin core.

I had a corruption issue so I’m following the troubleshooting guide on this

So to fix my issue, I needed to reindex to get core to actually sync back up, which it’s working now. Once synced up, we’ll see how Electrs does with syncing up.

you can follow the docker container with bitcoin core in it

ssh in


docker container ls -a

look for the container with bitcoind
for example

fb7771e777da getumbrel/bitcoind:v24.0.1

then type

docker logs --follow --tail fb7771e777da <---- your docker container ID here.

itll show where it is

CTRL+C to stop