Bitcoin core node stops syncing around 2%

Hello there,

Im new here and I already know this topic was posted here many times, but I have tried almost everything I found here and my node still stops syncing around 2 or 3 %.
I have tried to use fixed IP, set up correct time on my node, reinstallation of Bitcoin node and also many ssh commands which are 100% fully working to fix bitcoin node.

Also I have tried reindex=1 command. This one works in the way, that node does not stop synchronization. But every time around 2% it jumps to zero and start again.

Im starting to be really depressed…

Can someone please help??

2023-02-23T07:55:55Z Included configuration file umbrel-bitcoin.conf
2023-02-23T07:55:55Z Bitcoin Core version v24.0.1 (release build)
2023-02-23T07:55:55Z Using the ‘standard’ SHA256 implementation
2023-02-23T07:55:55Z Default data directory /data/.bitcoin
2023-02-23T07:55:55Z Using data directory /data/.bitcoin
2023-02-23T07:55:55Z Config file: /data/.bitcoin/bitcoin.conf
2023-02-23T07:55:55Z Config file arg: dbcache=“5722”
2023-02-23T07:55:55Z Config file arg: i2pacceptincoming=“0”
2023-02-23T07:55:55Z Config file arg: i2psam=“”
2023-02-23T07:55:55Z Config file arg: includeconf=“umbrel-bitcoin.conf”
2023-02-23T07:55:55Z Config file arg: listen=“1”
2023-02-23T07:55:55Z Config file arg: listenonion=“0”
2023-02-23T07:55:55Z Config file arg: onion=“”
2023-02-23T07:55:55Z Config file arg: onlynet=“ipv4”
2023-02-23T07:55:55Z Config file arg: onlynet=“ipv6”
2023-02-23T07:55:55Z Config file arg: onlynet=“onion”
2023-02-23T07:55:55Z Config file arg: onlynet=“i2p”
2023-02-23T07:55:55Z Config file arg: torcontrol=“”
2023-02-23T07:55:55Z Config file arg: torpassword=****
2023-02-23T07:55:55Z Config file arg: txindex=“1”
2023-02-23T07:55:55Z Config file arg: [main] bind=“”
2023-02-23T07:55:55Z Config file arg: [main] bind=“”
2023-02-23T07:55:55Z Command-line arg: blockfilterindex=“1”
2023-02-23T07:55:55Z Command-line arg: peerblockfilters=“1”
2023-02-23T07:55:55Z Command-line arg: peerbloomfilters=“1”
2023-02-23T07:55:55Z Command-line arg: port=“8333”
2023-02-23T07:55:55Z Command-line arg: rpcallowip=“”
2023-02-23T07:55:55Z Command-line arg: rpcallowip=“”
2023-02-23T07:55:55Z Command-line arg: rpcauth=****
2023-02-23T07:55:55Z Command-line arg: rpcbind=****
2023-02-23T07:55:55Z Command-line arg: rpcbind=****
2023-02-23T07:55:55Z Command-line arg: rpcport=“8332”
2023-02-23T07:55:55Z Command-line arg: rpcworkqueue=“128”
2023-02-23T07:55:55Z Command-line arg: zmqpubhashblock=“tcp://”
2023-02-23T07:55:55Z Command-line arg: zmqpubrawblock=“tcp://”
2023-02-23T07:55:55Z Command-line arg: zmqpubrawtx=“tcp://”
2023-02-23T07:55:55Z Command-line arg: zmqpubsequence=“tcp://”
2023-02-23T07:55:55Z Using at most 125 automatic connections (1048576 file descriptors available)
2023-02-23T07:55:55Z Using 16 MiB out of 16 MiB requested for signature cache, able to store 524288 elements
2023-02-23T07:55:55Z Using 16 MiB out of 16 MiB requested for script execution cache, able to store 524288 elements
2023-02-23T07:55:55Z Script verification uses 3 additional threads
2023-02-23T07:55:55Z scheduler thread start
2023-02-23T07:55:55Z [http] creating work queue of depth 128
2023-02-23T07:55:55Z Using random cookie authentication.
2023-02-23T07:55:55Z Generated RPC authentication cookie /data/.bitcoin/.cookie
2023-02-23T07:55:55Z Using rpcauth authentication.
2023-02-23T07:55:55Z [http] starting 4 worker threads
2023-02-23T07:55:55Z Using wallet directory /data/.bitcoin
2023-02-23T07:55:55Z init message: Verifying wallet(s)…
2023-02-23T07:55:55Z Using /16 prefix for IP bucketing
2023-02-23T07:55:55Z init message: Loading P2P addresses…
2023-02-23T07:55:55Z Loaded 17448 addresses from peers.dat 228ms
2023-02-23T07:55:55Z init message: Loading banlist…
2023-02-23T07:55:55Z SetNetworkActive: true
2023-02-23T07:55:55Z Cache configuration:
2023-02-23T07:55:55Z * Using 2.0 MiB for block index database
2023-02-23T07:55:55Z * Using 715.0 MiB for transaction index database
2023-02-23T07:55:55Z * Using 625.6 MiB for basic block filter index database
2023-02-23T07:55:55Z * Using 8.0 MiB for chain state database
2023-02-23T07:55:55Z * Using 4371.4 MiB for in-memory UTXO set (plus up to 286.1 MiB of unused mempool space)
2023-02-23T07:55:55Z init message: Loading block index…
2023-02-23T07:55:55Z Assuming ancestors of block 00000000000000000009c97098b5295f7e5f183ac811fb5d1534040adb93cabd have valid signatures.
2023-02-23T07:55:55Z Setting nMinimumChainWork=00000000000000000000000000000000000000003404ba0801921119f903495e
2023-02-23T07:55:55Z Switching active chainstate to Chainstate [ibd] @ height -1 (null)
2023-02-23T07:55:55Z Opening LevelDB in /data/.bitcoin/blocks/index
2023-02-23T07:55:55Z Opened LevelDB successfully
2023-02-23T07:55:55Z Using obfuscation key for /data/.bitcoin/blocks/index: 0000000000000000

can you give the info on your setup?

which machine are you using …


Hardware : BCM2835
Revision : d03140
Serial : 10000000e34faa9e
Model : Raspberry Pi Compute Module 4 Rev 1.0