1.0.4 seems to have broken uninstall

I’ve updated to 1.0.4 and have just tried to uninstall a couple of apps I was trying. Seems to work right until you press the red UNINSTALL button, then nothing happens. The only option is to cancel to get rid of the window.

@dmclark442 sorry to hear about your issue. Are you able to try to uninstall, then right after go to Settings > Troubleshoot > umbrelOS logs and then download the log file and upload it here. I’ll take a look and see if we can figure out what’s going on. Thanks!

umbrel_umbrel_2024-03-27_06-52.log (154.3 KB)
d here

Looks like Homebox might be a problem. It’s no longer installed.

Could you try installing a new app and uninstalling it?

Did you have Homebox installed before updating to 1.0?

I did not. I installed it, then uninstalled it after loading 1.0.4

This is where it fails:

umbrel_system_2024-03-27_08-07.log (159.1 KB)

@dmclark442 are you familiar with SSH to run through a few debug commands?

If so could you SSH in to your umbrel with ssh umbrel@umbrel.local using your dashboard password and share the output of

cat ~/umbrel/umbrel.yaml | grep -v otp
ls -lah ~/umbrel/app-data 

If not not worries I can walk you through it step by step.



Can you please try:

  • system restart from settings
  • was a minute for system to restart and apps to start up
  • install a random app from the app store (transmission is small and installs quick for testing)
  • wait for install to complete and the app to be available
  • uninstall test app
  • take logs from Settings > Troubleshoot > umbrelOS logs and upload here

umbrel_umbrel_2024-03-27_10-29.log (132.8 KB)

It uninstalled.

But others will not

You mean other apps won’t uninstall? Only the existing apps won’t uninstall or installing a fresh app and then uninstalling doesn’t work?

Also could you try viewing the page in private browsing mode and then uninstalling?

Installing that app, and uninstalling it, worked.

Previously installed apps still will not uninstall.

In Private mode, this button still does nothing

This uninstall button does not work for any of the currently installed apps.

Anything yet?

@lukechilds im having the same issue. This are the steps to reproduce it:

  1. Uninstall an app (it will work for the first one).
  2. Uninstall another app (then it will fail)

If I restart my umbrel I can delete the app again.

I inspected the request using the devtools and it seem that umbrel is trying to delete the previous unstintalled app, even though the payload sends the correct appId.

apps.uninstall yields:

Status: 500,
error.data.message: ENOENT: no such file or directory, open ‘/home/umbrel/umbrel/app-data/freshrss/umbrel-app.yml’

event though the payload is: { “appId”: “ghostfolio” }


one more thing I noticed is that even though the first uinstall successfully uninstall the apps, the request still returns a 500 error:

error: {message: "Cannot read properties of undefined (reading 'filter')", code: -32603,…}
code: -32603
data:  {code: "INTERNAL_SERVER_ERROR", httpStatus: 500,…}
message: "Cannot read properties of undefined (reading 'filter')"

I would gladly try to fix the issue myself in a PR, but the " Setting up a development environment" is missing in the umbrel repo :frowning:

1 Like