Problem with Docker on Umbrel 0.4.4

Docker doesn’t start


  1. apt-get update / reboot
  2. Reconfigure 0.4.4
  3. Downgrade to 0.4.1
  4. Update to 0.4.2
  5. Update to 0.4.3
  6. Update (again) to 0.4.4

In no instance will Docker start – same error as the below…

Several people in TG report the same issue.

goroutine 1 [running]:*freelist).free(0x4000c16e80, 0x183b, 0x7f48522000)
/go/src/ +0x39c

Please mention more details:

  • what system you use, RPi or PC/Linux
  • provide debug logs from your node
  • you said update. did you reflash the mSD card or just run the update?
    Also you have more solutions to read and try on Troubleshooting guide

I’m not the only one with this problem.
Raspberry Pi 4b 8gb

The Troubleshooting guide is very not useful in this instance.

There is a similar issue posted and I followed those steps (the update procedure).

This seems to be an issue with Docker. As I indicated, when I try to start docker, it fails. (/usr/bin/dockerd) …

Please advise as to how to resolve the docker issue. There are 3-4 others in TG with the exact same issue. Almost like an update (either 0.4.4 or docker) is causing the issue.

I don’t see any software issue in your logs.
Maybe you have a SSD failure or some files are corrupted from a previous shut down.
If you do not have funds in that node, I would suggest a total erase and start from scratch.
And use an UPS battery to protect it from micro fluctuations in electricity.

Again, SEVERAL OTHER PEOPLE on TG are having the exact same issue as reported today.

  1. It is on a UPS
  2. Again…check the error message from dockerd – I will pastebin it

I tried remove / install of docker

you should use

Yep. As I indicated, I have done that several times. After each update (0.4.1) I would run configure. Here’s what it does (fails because DOCKER fails).

And yes, I backed up the LND.conf file before doing that.

And if they can stop banning pastebin that would be great.

Hey @JeffersonNunn.

Have you tried to reflash the microSD card? I can’t see the answer to @DarthCoin’s question.

Reflashing means waiting a whole TWO weeks for the blockchain to synchronize again. And clearly it’s something wrong with docker. I’ve tried doing configure and redownloading umbrel. Again it’s something with docker…

I was able to figure it out after a lot of hacking.

I should write this up but maybe someone else can. I went in and did the following (after figuring it out):

apt-get remove docker*
apt-get remove container*
apt-get clean and so on to really make sure cache of it was all clean
unmount /var/lib/docker
mv /var/lib/docker /var/lib/docker2
apt-get install docker-ce*
apt-get install container*

That last command remade all the containers
And now my node is up. Someone should probably go through this idea and refine it and turn it into a “rebuild umbrel binaries” command so we don’t have to reflash. This is Docker, after all.

I know what reflashing means and it does not include resyncing the chain. All the data is kept on the SSD, the microSD card only contains and runs the operating system. Reflashing it allow you to have a clean OS and fix packages, caches, etc issues.

I completely understood that the issue was Docker, I looked at the same logs as you. I also know this issue and know how to solve it. That’s why I asked you if you had tried to reflash the microSD card. But you won’t listen to @DarthCoin or me.

Executing these, you can break your Umbrel. All the Docker dir is mounted from the SSD. If you move this folder or unmount it, Docker data will be written to the microSD card instead of the SSD.

I’d suggest again to reflash the microSD card with the latest version v0.4.5, and report back afterwards.