Error: No external drive found

Hello there,

I know that there is already some post about this issue, but even after reading it all and tried several different solutions, I’m still stuck to launch my node.
So little recap:

  • I’ve bought first all parts of my Pi, excepted the Orico case, and the official supply, i already have a PSU like that and i would not put my SSD in a case as i have a box dedicated to this.
    I’ve mount it all, launch the Pi, and so i have the Error: No external drive found.
    So i bought an Orico case as recommended, and magic it worked, node sync at 55% when i decide to shutdown the pi to finally put it in his case, reboot… and then this F*****g Error: No external drive found again…

So i bought an official PSU, and then now i have all recommended parts, and it still not work.
I have flashed the SSD between every step or try.

I saw on other topic for this issue that sometime, direct link with no Orico case fixed it… so i really dont know what to do next.

Thanks in advance for your help.

Sounds painful. I was having a problem with the SSD case, had to shut down and unplug and restart a bunch of times. There was no real rhyme or reason to it. One thing that seemed to help was to take the back off the SSD case. I would also shutdown the Pi and unplug everything. I think reflashing the SD card would be unnecessary.

Yeah i seen your message about that, have tried it, no change…

Yes i will try that another time.

This issue start to made me feel mad…
After my last message here, i’ve again flashed the SD a few times, unpluged and repluged everything, and for no reason it worded one time, so i let the synch work, it took 6 days.

So then i just shut off the Pi for some manipulation, after reboot, this damn message again…
Kind of desperate here, will let it in a corner a few days and will have a look on it again when less upset.