Umbrel Troubleshooting Guide

You are doing it WRONG!
Do not update through Lightning Shell app!

The procedure for manual updating is very clear (and all commands in the /umbrel/ folder):

  1. stop umbrel scripts
  2. update OS system (if your machine is not Rasp Pi)
  3. restart machine
  4. run the Umbrel manual update script command
  5. start umbrel script
    Done
1 Like

Hey, thanks for the response.
Well as you can see from the screenshot I have tried to use the commands on the FAQ.
I’m running it on Rasp Pi. Just looked into stop umbrel script on github. It goes like this:


Would you mind giving me the command order so I can learn this process?
Thanks.

Try rm -f ~/umbrel/statuses/update-in-progress && sudo ~/umbrel/scripts/update/update --repo getumbrel/umbrel#v0.4.14

I restored my Umbrel node from seed but my balance is zero.

I upgraded my Pi Umbrel from a 1TB to a 2TB hard drive. I managed to close out my LND channels and return all the sats to my Bitcoin Wallet using the commands provided, but the wallet was incorrect.

I followed the instructions, but now my Bitcoin Wallet balance is 0. I created a wallet in BlueWallet with the original Umbrel seed phrase and see that all the sats are there, so I know I have not lost anything, but would like to know if the commands here should restore the transaction history on Umbrel. Thanks!

If you already have all the funds in Bluewallet I would suggest to reset your user data and start from scratch (without re-sync). See the troubleshooting manual the section about reset user data.
Seems that you didn’t read the dedicated guide for restoring or moving old node to new node, or you didn’t copied correctly the data from the old drive and that end up in starting a new reindex and rescan of the addresses.

You should look into your electr logs and bitcoin logs and have patience to wait until the rescan is done.

I read the How to restore your node wallet, which is how I got as far as I did. This was how I restored my funds for my LND channels, but could not seem to restore the sats to the Bitcoin Wallet.

I could certainly try again with step 1, but I do not believe that will show the funds in the Bitcoin Wallet again. I came to the same conclusion as your recommendation about starting over and transferring the funds to the new Umbrel node wallet, but wanted to check to make sure there was not another way to keep the same seed phrase and capture the transactions from the blockchain. It seems odd to me that I cannot force the Bitcoin Wallet to rescan the entire blockchain for my transactions.

Is there a way to delete, recreate, and reload the blockchain on my new 2TB SSD via command line? Would that even make a difference?

@DarthCoin you are an amazing Force to be reckoned with in this community and are consistently helpful to all of us learning about Umbrel. Thanks man! I appreciate you.

Noooo! Do not do that again? You already did enough damage.
For migrating a node from one disk to another, simply have to copy the whole disk using an image cloning software, or simply copying the Umbrel folder.
You do not have to close the channels, using the restore procedure. That is done ONLY if previous disk is damaged or data cannot be retrieved.

As I said: now that all your funds are already in Bluewallet, just reset your umbrel user data (see in the troubleshooting manual):

Enter using SSH and run the following:

sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm ~/umbrel/db/user.json && sudo rm ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

This will create a new node id, new wallet, new seed, start fresh, forget about old nodeid.
Then you can just send the funds using Bluewallet to your new umbrel wallet and open new channels.

I saw the, “Noooo! Do not do that again? You already did enough damage.” pop up on my notifications and it made me laugh out loud. Thank you for your help. I will do that. I appreciate all your help. I can follow those simple instructions.

If you already initiated that recovery of funds and you have all channels closed and funds back in onchain… there is no need anymore for that old node id. Forget it.

1 Like

@DarthCoin After updating to Umbrel Version 0.4.15 all my sats are now showing in my Bitcoin Wallet, so I do not need to run the command you provided previously. Thank you for all your help.

1 Like

This was a life saver, thank you. As a note, I had to add the peer on the uploading node before it would add to the peer list

Hello Darthcoin, thanks for your useful guides!
I restored my umbrel due to the neef of updating to a bigger SSD drive. After introducing the seeds and once downloaded 100% of the blockchain, I still dont see my bitcoin funds. I followed your troubleshooting on " I restored my Umbrel node from seed but my balance is zero" two times with no success.
Just to verify: when introducing this command { sed -i ‘/reset-wallet-transactions=true/d;’ ~/umbrel/lnd/lnd.conf }, is one or two separate commands? should i expect to see any reaction on the command promt?

Before doing such a big move, why you didn’t read carefully my dedicated guide or at least ask here first?
http://community.umbrel.com/t/how-to-restore-your-node-wallet/
There’s a section 7 exactly for this where is explaining how to move to another hardware.
There’s NO need to use the seed!
Now you messed up things more.

You will need first to let the node to resync 100% and let electrs to finish the index, then start the restore from seed + backup.
After that you need to wait up to 144 blocks until all your channels will be closed and funds back.
THIS PROCESS TAKE TIME! Have patience please, before doing anything else.

Hello Darthcoin, thanks for your time. In fact I´ve been very patient.
Some months ago I already read many of your fantastic guides, since I had an issue with some corrupted blocks reported on the logs, so I tried to perform at that time the restore of my node following the same guide you sent yesterday.
However, maybe due to my lack of technical knowledge (it is a big effort to me to type on the command prompt…), at that time my node did not restore correctly. The umbrel community helped me realize that I needed to to update my SSD, because its capacity was 500 GB and was not enough. Since I live in Venezuela, It took me a couple of months to import a compatible 1 TB SSD from the US. When i received the new SSD, I introduced my old node seed, and started syncing the blockchain.
My situation now is that i have all the blockchain 100% synced, but both btc and LND wallets still show synchronizing message. This is the reason why I tried to follow your “I restored my Umbrel node from seed but my balance is zero” guide.
Here you have my logs: https://pastelink.net/rgjewh6o
So now I just have to wait? I have no issue for waiting, i just want to know if there is anything else i have to do. For instance, I don´t know how to check if electrs has finished the index…
Sorry for my lack of expertise… I hope I’m not bothering you…
Regards

Is it explained in the troubleshooting guide:
cd umbrel
docker-compose logs electrs

And see at what height of blocks is still indexing.

In regards your logs it says very clearly:
lnd | 2022-05-06 01:38:21.583 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet not created, create one to enable full RPC access

So you didn’t restored correctly or the process didn’t finished.

I suggest to reset the whole instance and start over with a new node instance, new seed new wallet, clean.

Old wallet, if you had funds in it, restore it in Zap, BW or Blixt (see the specific situation in the guide about restore dead node).

Thanks. I will follow your suggestion this afternoon as soon as i get home. Just a fast question: when reseting the whole instance with a new node instance, new seed new wallet, will I have to download again all the blockchain or I could use the one that it is already downloaded to my new 1Tb SSD?

No, check in the troubleshooting manual the section where is explained. All blockchain data remain.

1 Like

Maybe make this bold, I didn’t look carefully enough to see that 0.4.8 is NOT the same as 0.4.18, and I ended up rolling my node back a whole bunch of versions and in the process losing all the apps that didn’t exist back then :wink:

Hahaha good that you realize that. It should be ok just updating the correct version.

I think is wrong, it should be: sudo ./scripts/start

Also, for stop, it should be:
sudo ./scripts/stop