Umbrel keeps overwriting DNS values with and

This is a problem, because in the country my server is in, these DNS servers are blocked :frowning:. I’ve tried various methods, including adding supersede domain-name-servers [address of router]; to the dhcp.conf and restarting, but something continues to overwrite the resolv.conf with Cloudflare and Google DNSs. Note that the above change to dhcp.conf shouldn’t be required, since the DHCP server is providing the correct values.

Any idea what’s causing this and how to stop it? Thanks!


I think this may have started with the attempt to update to 0.5.1, as per Umbrel 0.5.1 is out with app release notes and bug fixes

I’ve tried using iptables to remap and to my router/dns proxy, which works for dns lookups on the command line, but most of the apps are still stuck on “starting”.

1 Like

Just found these:

./scripts/update/ "nameserver" >> "${RESOLV_CONF_FILE}"
./scripts/start:DEVICE_IP="$(ip -o route get to | sed -n 's/.*src \([0-9.]\+\).*/\1/p')"

Its hardcoded right and they arent addressing the issue. The issue being that it is hardcoded.

1 Like

Added my 2 local pihole dns IP addresses in resolv.conf which allowed me to run the update. Unfortunately resolv.conf gets re-written with Google DNS at reboot.

If this isn’t fixed then Umbrel isn’t for me unfortunately. :frowning: