SSD keeps disconnecting

Got same issue but in the other way.
Have bought first all good recommended part, excepted the orico box, umbrel wasnt working and gave me the typical SSd error page…

So i bought a Orico box, as recommended…
It work, 2 days…
I had to restart the node after 2 days to move it from his place, and after reboot , again this stupid SSD error…
Dont know what to do seriously…

1 Like

I’m going to do the same thing and just ordered a direct cable.

The direct cable solved all the issues.


What do you mean by a direct connection cable? I’m having exact same issues with the Orico

i mean just a cable, with no box …
But it doesnt work for me, gonna reflash the SD again, and try again…
Really dont understand why suddenly this orico box doesnt fit anymore…
Also, i see a lot of people posting here about that SSD issue, lot solve it, but a lot seems to never find a solutions.
Sad that this issue is not more documented

Just going from SATA to USB3 with a cable like this ( USB 3.1 to 2.5" SATA Hard Drive Adapter) and skipping the enclosure.


Try another usb port. Blue one works fine for me with direct cable. As for documentation, that’s what we are doing here )

1 Like

I’m going to mark this resolved tomorrow if the connection lasts a full day, but so far this is the way to go instead of the Orico enclosure. The Orico never stayed connected for more than 12 hours, and usually failed well before that.

1 Like

I was having this same problem with the same gear. I don’t know why, but I took the back cover off the ssd case and it seemed to improve the reliability a lot - I could at least move the parts around my desk and not have it disconnect. I ended up getting a dedicated SSD to USB wire, will see how the works. I do not think Umbrel should recommend this SSD case anymore.

I also got a SATA to USB cable and it immediately ran for over 24 hours without any issues so I agree the recommended case is the issue.

1 Like

Same exact issue as you. Drop the Orico case and just go direct from SSD via SATA III to USB 3.0. Node has been working flawlessly for me now for 2 weeks.


I just marked this as the solution. Seems rock solid now after ditching the Orico case. Umbrel should probably remove this case from their list of recommended parts.


I finally bought an official PSU, so i have all recommended part…
Then it still wont work, with the orico case or the direct link, still had the issue of “no external drive found”

Are you using the USB3 (blue) port on the Pi?

of course ^^

I’m in the same boat; did you get the thing a they are suggesting?

Did it work?

I got the direct cable, reflashed etc. and now i get this

ok so 3rd usb port out of 4 and it worked. happy days!!

Got the same everytime i try to launch…

So it work just by changing the usb port?