# RESERVED WALLET Balance invalidated ):

**URL:** https://community.umbrel.com/t/reserved-wallet-balance-invalidated/4431
**Category:** Bitcoin and Lightning
**Created:** [November 1, 2021, 12:43am UTC](https://community.umbrel.com/t/reserved-wallet-balance-invalidated/4431 "2021-11-01T00:43:29Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)
#### Post date: [November 1, 2021, 4:27pm UTC](https://community.umbrel.com/t/reserved-wallet-balance-invalidated/4431/2 "2021-11-01T16:27:46Z")

</div>

This is not an issue related to Umbrel in specific. Is a bug in LND and was addressed here

> <https://github.com/lightningnetwork/lnd/issues/5866>
>
> \### Background
> 
> Tried to open a channel, peer is online, I have enough funds i…n onchain, like 2.7M sats in 1 UTXO.
> I always get an error that doesn't say too much:
> \`reserved wallet balance invalidated\`
> 
> \### Your environment
> 
> \* LND v.13.3
> \* Debian 10
> \* Umbrel node v 0.4.4 (latest)
> \* 35 other channels open, working fine, routing etc, with total liquidity of almost 30M sats
> 
> \### Steps to reproduce
> 
> I used RTL, Thunderhub, Umbrel dashboard, lncli, Zap mobile/desktop, Zeus to try to open a channel of 2 or 2.5M sats
> Error in RTL: reserved wallet balance invalidated
> Error in Thunderhub: failed to open channel
> Umbrel: reserved wallet balance invalidated
> Zap, Zeus: reserved wallet balance invalidated
> lncli: rpc error: code = Unknown desc = reserved wallet balance invalidated
> Whatever amount I put, is the same message, that doesn't say too much, what should I do or how to fix it.
> I looked for more documentation and I found that is due to new feature release of anchor output reserve, but there is no place to explain how to deal with this "reserve", there's no specific amount that user can know to keep or use in "reserve", nothing.
> 
> I tried also disabling this feature editing the lnd.conf file with
> \`\[protocol\]\`
> \`protocol.no-anchors=true\`
> restart lnd, tried again, same error
> 
> \### Expected behaviour
> 
> \- To have a damn explanatory message saying what to do or calculate or send to specific documentation.
> \- Leave only the commit fees to calculate this reserve and deduct from the amount the necessary fee/reserve
> \- make a way that user will see and label that specific reserve in a UTXO and be clear that is not to be touched/moved from that wallet. Also to not be reflected into "available balance".
> 
> \### Actual behaviour
> Can't open channels and also I don't know or calculate how much I should have in "reserve".
> Right now is just confusing, how much is in "reserve" and how much is available to spend. nobody knows that, none of wallet apps is showing that.
> This will just create more issues and chaos with so many noobs running nodes.
> 
> \*\*Please advise how to deal with this. Make a specific documentation for users, it is very confusing.\*\*
> 
> \### Additional references
> https://bitcoinops.org/en/topics/anchor-outputs/
> https://github.com/lightningnetwork/lnd/issues/5599
> https://github.com/lightningnetwork/lnd/issues/5648
> 
> I also posted some requests / fixes to these apps, to see if more people come up with a nice solution:
> https://github.com/Ride-The-Lightning/RTL/issues/833
> https://github.com/apotdevin/thunderhub/issues/352
> https://github.com/getumbrel/umbrel-lightning/issues/29
> 
> EDIT
> additional test:
> I sent 100k sats to a new UTXO to the node wallet.
> Still doesn't let me to open a channel with the 2.7M sats, whatever amount I try to use.
> This is getting ridiculous.
> 
> Another question: when I open a channel how do I know that is not taking from this "reserve" UTXO, how do I make coin control when I open a channel in TH, RTL, Zeus, Zap etc...

Options that you have now are:

- send a 100k sats to your node onchain address, in one UTXO
- keep that UTXO untouched, as reserve for future opening channels
- add this line in your lnd.conf at the end of the file  
`[protocol]`  
`protocol.no-anchors=true`
- restart the node
- try again opening the channel. If still can’t open, try sending more UTXOs to your node, but at that level is not realistic anyway and you should wait fro the new version of LND v 0.14

THIS IS BUG IN LND! And a much better approach is to not open channels until v 0.14 with a fix will be released.

---

_[View the full topic](https://community.umbrel.com/t/reserved-wallet-balance-invalidated/4431)._
