Opening Channel transaction with pushed sats not in mempool. Help?

I opened a 3m sats channel to Lightning2me yesterday and I pushed half the sats to them for them to return on chain.

The problem is that the channel is pending open and the transaction ID does not exist in the mempool. This has never happened me before and I have opened plenty of channels.

In my Lightning wallet it says my pending balance is just under 1.5m; I guess that is because the remote balance has the other 1.5m?

I emailed lightning2me and they said if the sats show up in their wallet they will refund to me, but unsure what is the best solution for me here. Are the sats actually in their control yet in as the channel is at pending open status?

I tried restarting my node to try to re-broadcast the channel opening transaction, but that didn’t do anything.

Any help appreciated in closing this out please to either ensure this channel opens or else just cancel it and ideally return the 3m sats to me, or in a worst case return my 1.5m and push through the 1.5m to lightning2me so they can be refunded to me.

EDIT - As I’m reconciling my on chain wallet balance on Umbrel I don’t think I have enough sats to have been able to create the 3m channel. Unsure how it would have let me try to open the channel on that basis, but that might be one reason why my transaction is in this position. Would that make sense?

Always use Thunderhub or RTL app to open channels.
In Thunderhub also you have the option to use keysend to push funds on the other side.
Is possible you openeed a channel with some not all confirmed utxos and now is in limbo for low fee.
Just wait a bit longer until it gets into mempool.
In Thunderhub, go to channels - pending - and click on the tx and you can see the txid that can be followed in mempool

Thanks for the reply and I did open it in Thunderhub and used the Push function at the time of opening the channel.

And my main difficulty t is that the transaction ID that I get for the channel opening does not exist in the mempool!
And during the time since I did it the mempool was empty, ie 1 sat fees were getting processed.

check it on the public, NOT on your own node mempool

Same on the public mempool space

Try this, just to check before doing other crazy things.
Import the seed in Bluewallet or Sparrow or Zap (desktop). Just to see if the tx or funds are back to your onchain.
Follow the instructions from this guide if you want to use Sparrow.
If the funds are back, then you could start the process of re-scan utxos in your umbrel.

So before I read your last message I decided to force close it as it said I have 0 funds in limbo.

I ran closechannel force command and it generated me a closing_txid

When I enter that new closing_txid in mempool I get the same “transaction not found” message. Talk about being confused!!