Ledger hardware wallet

I’m looking for a tutorial to connect my hardware Ledger wallet to Getumbrel.

Any advice? Thanks.

1 Like

Yes, I’m looking for the same thing… not sure how to find my RPC Credentials

Don’t bother trying to do this with Ledger Live and Satstack, or with HWI Bridge (Specter Desktop to Specter App on Umbrel).

Download Specter Desktop from the Specter website

In Specter Desktop preferences: Do you want to connect to a remote Specter? No, run Specter locally

Specter > Bitcoin Core > Existing Node
Connect Specter Desktop to your Umbrel node using the info found here, then click “Test” to verify if Specter Desktop is able to connect to your Umbrel.

Specter > Settings > Tor
Make sure Tor is enabled on Specter Desktop. You don’t need to install Tor on your computer, Specter Desktop has this built-in. Also, Do outside calls only over Tor? Toggle this switch on.

Specter > Settings > USB Devices
Make sure Local USB Connection is selected.

Connect your Ledger to your computer and create a new device (Ledger), then a new wallet (Native Segwit, Segwit or both). After choosing the device, click continue, then select the: “Scan for existing funds” checkbox on the next screen. It’s probably better to scan the whole blockchain instead of UXTOs so it can pick up all your transactions.

You can now use Specter Desktop just as you would Ledger Live to check UXTOs, send and receive. You never have to use Ledger Live again.

And every past and future transaction can be viewed using BTC RPC Explorer and Mempool running on your node:

Specter Desktop > Preferences > General > Miscellaneous

  • Block explorer URL (main): Select custom, then enter http://umbrel.local:3002/ (BTC RPC Explorer) or http://umbrel.local:3006/ (Mempool)
  • Fees estimation source: Select Self hosted mempool.space, then enter http://umbrel.local:3002/ (BTC RPC Explorer) or http://umbrel.local:3006/ (Mempool)

This is what I was looking for…thanks very much. Will give it a shot. Anybody else try this? Is it safe to connect your ledger to the Specter Desktop?

I have connected a Ledger to Specter but I run Specter by itself and point it to the node. Doing it this way allows one to update Specter as soon as an update is available rather than waiting for Umbrel. Not saying Umbrel is slow, but if there is ever the need for a quick update it can be done at will.



But what about safety? After all the Ledger is supposed to be a cold wallet. So what do I open to the internet with this connection?

Or reasoned the other way around, why wouldn’t this solution compromise safety?

Thanks Full_node…I appreciate the response. Do you know if you can still use Ledger Live and the mobile Ledger Live app as well I understand that they would be connecting via the Ledger servers and not your personal node but was wondering if you can still use if you would like to. Thanks again

1 Like

It’s safe to connect your Ledger to Specter Desktop.

Specter uses your extended public key (xPub) generated by the Ledger to scan for your existing addresses on the blockchain.

Your private key remains safely on the Ledger and is never touched, even when the Ledger is connected to your computer.

You can still use Ledger Live and the mobile Ledger Live app together with Specter.

Think of Specter as an alternative to Ledger Live with the main distinction being, you are using your own node instead of Ledger’s node(s).

When I set this up, something really clicked for me. This is the part where you truly become your own bank IMHO. Checking your UXTOs, performing ingoing/outgoing transactions against a public ledger that you know to be accurate (your own node).


Wow…thanks Grinder. Your explanation is very clear and helpful. Love the idea of being my own bank!

1 Like

Thank you very much for your help and great explanation. Much obliged!! :muscle::rocket:

1 Like

Thanks for sharing this. I’m a new Umbrel user and really wanted to get my Ledger working with my own node. I was struggling until I found your post.
All up and working now. Specter runs a bit slow compared to Ledger live but it works and at least I have the option of using my own node to confirm my transactions now

Grinder, may I ask you 2 additional questions?

  1. How do I add an additional account of my Ledger (I have more accounts, but only one of them is found by Specter).

  2. Why Specter Desktop and not the Specter app in the Getumbrel library of the Raspberry PI


When you first add Ledger as a device to Specter Desktop and connect your Ledger via USB, Specter Desktop should scan for all available xPubs on the Ledger.

So, for example, you’ve created 2 accounts in the past using Ledger Live say, Segwit and Native Segwit.

Specter Desktop will recognise those 2 accounts and import the keys. You can then add a new wallet for each account in Specter Desktop. What Ledger calls ‘accounts’ are basically ‘wallets’ in Specter Desktop.

  1. For Segwit on the Ledger, you would choose Nested in Specter Desktop
  2. For Native Segwit on the Ledger, you would choose Segwit in Specter Desktop

You can definitely add more keys to Specter Desktop under the devices section, and technically it should be able to detect and pull in all your accounts if your Ledger is connected via USB.

As for why the desktop app and not the app on the node… I don’t think you can connect a hardware wallet to the node and get the Specter App on the node to recognise it (at least, I could not get it to work that way).

So I didn’t see the point of running in HWI bridge mode and using 2 Specters (desktop and Umbrel) if my primary usage would be connecting my hardware wallet directly to my computer.

Thanks Grinder,

Ok, but:…

Segwit on the Ledger, chose Nested in Specter Desktop, found only 1 account/wallet. Also when I tried again with a fast scan. (my Ledger Live says my accounts are segwit) (I did a full scan of the blockchain)

I tried more devices, tried also adding more keys, but that didn’t give a new result (I mean, well, I couldn’t find it…)

To be complete I tried native segwit on the ledger, segwit in specter desktop, but then nothing was found.

So now I have 2 devices and 3 wallets, but still only one of my Ledger accounts (and corresponding balance) to be found.

Regarding your last point, I tried it on the node as well with specter and found the same as you, I couldn’t get it to work.


Thanks again Grinder. I’m having no luck getting my M1 MacBook Air to recognize my Leger via USB on the Specter Desktop App. Ledger Live can find and connect to my Ledger Nano X via USB but the Specter Desktop just can’t find the Ledger via USB. Maybe a M1 MacBook issue with Specter? I’m not sure…anybody else get their M1 Mac to connect to Specter via USB ?

You could try…

With your Ledger connected to the MA…

And when you’re adding a new device and click “Get via USB”, you should see " Detecting…Plug in your device"

Once plugged in, make sure you press the left and right buttons on the Ledger simultaneously to make the connection. Just plugging the Ledger in doesn’t allow Specter Desktop to detect it.


Thank you Grinder. I tried what you recommended but no luck. LedgerLive works fine but Specter will not recognize the Ledger via USB. Perhaps Specter doesn’t support M1 Macs yet? I’ll do some more research to see if I can find out what is going on. Again, appreciate the support.

I am still in the process of getting my Umbrel fully operational.

With Specter Desktop on MacOS it worked for me: But it took me a while to figure out that I have to unlock the Ledger AND chose the Bitcoin App on the device (I have many). I guess that is the same comment that grinder is making about pressing both buttons. Seems obvious in hindsight but it took some swearing.

I never succeeded to get Specter on the Umbrel to detect the USB device (Ledger) - no idea why. But like grinder I will anyways use it over the Mac.

Great point byebyepetrodollar about unlocking the Ledger and choosing the Bitcoin app.

It worked! Thank you so much, Grinder and byebyepetrodollar! You were right…you have to unlock the leger, select the Bitcoin App AND press both buttons at the same time. Lots of swearing indeed but it finally worked! Thank you!