# Failed to Start Docker Application Container Engine

**URL:** <https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816>\
**Category:** Support and Troubleshooting\
**Created:** [July 21, 2022, 4:22pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816 "2022-07-21T16:22:23Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![OpenWaterSwim](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/openwaterswim/32/2014_2.png) [@OpenWaterSwim](https://community.umbrel.com/u/OpenWaterSwim)\
**Post date:** [July 21, 2022, 4:22pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/1 "2022-07-21T16:22:23Z")

</div>

I began running Umbrel successfully nearly a year ago with minimal issues on several nodes. I recently lost power and one of my nodes returned as normal, but the other did not. I have a bitcoin wallet and lightning channels on this node. I have my seed and backups. Connecting via browser, I receive the following **Error: Failed to start containers**.

 ![CannotStartContainer](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/5/55a03cef0f4dd1b2e8e90f2e22ea9651ae916133.jpeg)

I am able to connect via ssh and verify that the SD card with the OS and SSD drive are functional, but continually receive this error when connecting via any browser. I bought a new micro SD card and flashed it to Umbrel v0.5.0. One interesting note is that my password reset to the default password when I began receiving this error.

* * *

Here is my setup:

- Raspberry Pi 4B - 8GB
- Samsung Portable SSD T7 - 2TB
- SanDisk 32GB Ultra microSDHC UHS-I Memory Card
- GeeekPi Armor Lite Aluminum Heatsink with PWM Speed Control Fan for Raspberry Pi 4 Model B

Here is the debug log from this Umbrel node.

* * *

# ===================== = Umbrel debug info =

## Umbrel version

0.5.0

## Flashed OS version

v0.5.0

## Raspberry Pi Model

Revision : d03114  
Serial : 10000000678aebdd  
Model : Raspberry Pi 4 Model B Rev 1.4

## Firmware

Dec 1 2021 15:01:54  
Copyright (c) 2012 Broadcom  
version 71bd3109023a0c8575585ba87cbb374d2eeb038f (clean) (release) (start)

## Temperature

temp=37.4’C

## Throttling

throttled=0x0

## Memory usage

```
          total used free shared buff/cache available

```

Mem: 7.8G 115M 7.3G 8.0M 361M 7.6G  
Swap: 4.1G 0B 4.1G

total: 1.5%  
system: 1.5%  
tor: 0%  
ride-the-lightning: 0%  
mempool: 0%  
lnd: 0%  
lightning: 0%  
electrs: 0%  
electrs: 0%  
btcpay-server: 0%  
bitcoin: 0%  
bitcoin: 0%

## Memory monitor logs

2022-07-21 16:02:17 Memory monitor running!  
2022-07-21 16:02:29 Memory monitor running!  
2022-07-21 16:02:40 Memory monitor running!  
2022-07-21 16:02:52 Memory monitor running!  
2022-07-21 16:03:04 Memory monitor running!  
2022-07-21 16:03:16 Memory monitor running!  
2022-07-21 16:03:28 Memory monitor running!  
2022-07-21 16:03:40 Memory monitor running!  
2022-07-21 16:03:52 Memory monitor running!  
2022-07-21 16:04:04 Memory monitor running!

## Filesystem information

Filesystem Size Used Avail Use% Mounted on  
/dev/root 29G 3.2G 25G 12% /  
/dev/sda1 1.8T 534G 1.2T 31% /home/umbrel/umbrel

## Startup service logs

Jul 21 16:04:04 umbrel umbrel startup[32709]: Starting backup monitor…  
Jul 21 16:04:04 umbrel umbrel startup[32709]: Starting decoy backup trigger…  
Jul 21 16:04:04 umbrel umbrel startup[32709]: Starting Docker services…  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The TOR\_PROXY\_PORT variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The TOR\_PROXY\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The NGINX\_PORT variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The NGINX\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The DASHBOARD\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The MIDDLEWARE\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The UMBREL\_AUTH\_SECRET variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_P2P\_PORT variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_RPC\_PORT variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_RPC\_USER variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_RPC\_PASS variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_NETWORK variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The MANAGER\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The BITCOIN\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The LND\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The AUTH\_PORT variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The AUTH\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The NETWORK\_IP variable is not set. Defaulting to a blank string.  
Jul 21 16:04:05 umbrel umbrel startup[32709]: The Compose file ‘./docker-compose.yml’ is invalid because:  
Jul 21 16:04:05 umbrel umbrel startup[32709]: networks.default.ipam.config.subnet is invalid: should use the CIDR format  
Jul 21 16:04:05 umbrel umbrel startup[32709]: services.tor\_proxy.ports contains an invalid type, it should be a number, or an object  
Jul 21 16:04:05 umbrel umbrel startup[32709]: services.auth.ports contains an invalid type, it should be a number, or an object  
Jul 21 16:04:05 umbrel umbrel startup[32709]: services.nginx.ports contains an invalid type, it should be a number, or an object  
Jul 21 16:04:05 umbrel umbrel startup[32709]: Failed to start containers  
Jul 21 16:04:05 umbrel systemd[1]: umbrel-startup.service: Control process exited, code=exited, status=1/FAILURE  
Jul 21 16:04:05 umbrel systemd[1]: umbrel-startup.service: Failed with result ‘exit-code’.  
Jul 21 16:04:05 umbrel systemd[1]: Failed to start Umbrel Startup Service.

## External storage service logs

– Logs begin at Thu 2022-07-21 15:17:01 UTC, end at Thu 2022-07-21 16:04:05 UTC. –  
Jul 21 15:17:06 umbrel systemd[1]: Starting External Storage Mounter…  
Jul 21 15:17:06 umbrel external storage mounter[486]: Running external storage mount script…  
Jul 21 15:17:06 umbrel external storage mounter[486]: Found device “Samsung PSSD T7”  
Jul 21 15:17:06 umbrel external storage mounter[486]: Blacklisting USB device IDs against UAS driver…  
Jul 21 15:17:06 umbrel external storage mounter[486]: Rebinding USB drivers…  
Jul 21 15:17:06 umbrel external storage mounter[486]: Checking USB devices are back…  
Jul 21 15:17:06 umbrel external storage mounter[486]: Waiting for USB devices…  
Jul 21 15:17:07 umbrel external storage mounter[486]: Waiting for USB devices…  
Jul 21 15:17:08 umbrel external storage mounter[486]: Waiting for USB devices…  
Jul 21 15:17:09 umbrel external storage mounter[486]: Checking if the device is ext4…  
Jul 21 15:17:09 umbrel external storage mounter[486]: Yes, it is ext4  
Jul 21 15:17:09 umbrel external storage mounter[486]: Checking if device contains an Umbrel install…  
Jul 21 15:17:09 umbrel external storage mounter[486]: Yes, it contains an Umbrel install  
Jul 21 15:17:09 umbrel external storage mounter[486]: Bind mounting external storage over local Umbrel installation…  
Jul 21 15:17:09 umbrel external storage mounter[486]: Bind mounting external storage over local Docker data dir…  
Jul 21 15:17:09 umbrel external storage mounter[486]: Bind mounting external storage to /swap  
Jul 21 15:17:10 umbrel external storage mounter[486]: Bind mounting SD card root at /sd-card…  
Jul 21 15:17:10 umbrel external storage mounter[486]: Checking Umbrel root is now on external storage…  
Jul 21 15:17:11 umbrel external storage mounter[486]: Checking /var/lib/docker is now on external storage…  
Jul 21 15:17:11 umbrel external storage mounter[486]: Checking /swap is now on external storage…  
Jul 21 15:17:11 umbrel external storage mounter[486]: Setting up swapfile  
Jul 21 15:17:11 umbrel external storage mounter[486]: Setting up swapspace version 1, size = 4 GiB (4294963200 bytes)  
Jul 21 15:17:11 umbrel external storage mounter[486]: no label, UUID=74b6f1ed-4f73-4531-9e47-7fb91be3ddf0  
Jul 21 15:17:11 umbrel external storage mounter[486]: Checking SD Card root is bind mounted at /sd-root…  
Jul 21 15:17:11 umbrel external storage mounter[486]: Starting external drive mount monitor…  
Jul 21 15:17:11 umbrel external storage mounter[486]: Mount script completed successfully!  
Jul 21 15:17:11 umbrel systemd[1]: Started External Storage Mounter.

## External storage SD card update service logs

– Logs begin at Thu 2022-07-21 15:17:01 UTC, end at Thu 2022-07-21 16:04:05 UTC. –  
Jul 21 15:17:19 umbrel systemd[1]: Starting External Storage SDcard Updater…  
Jul 21 15:17:19 umbrel external storage updater[938]: Checking if SD card Umbrel is newer than external storage…  
Jul 21 15:17:19 umbrel external storage updater[938]: No, SD version is not newer, exiting.  
Jul 21 15:17:19 umbrel systemd[1]: Started External Storage SDcard Updater.

## Karen logs

karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events

## Docker containers

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

## Umbrel logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor\_proxy.ports contains an invalid type, it should be a number, or an object  
services.auth.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object

## Tor logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor\_proxy.ports contains an invalid type, it should be a number, or an object  
services.auth.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object

## App logs

bitcoin

./scripts/app: line 81: NETWORK\_IP: unbound variable

btcpay-server

./scripts/app: line 81: NETWORK\_IP: unbound variable

electrs

./scripts/app: line 81: NETWORK\_IP: unbound variable

lightning

./scripts/app: line 81: NETWORK\_IP: unbound variable

mempool

./scripts/app: line 81: NETWORK\_IP: unbound variable

ride-the-lightning

# ./scripts/app: line 81: NETWORK\_IP: unbound variable

# ==== Result ====

The debug script did not automatically detect any issues with your Umbrel.

* * *

**Here is the docker.service status.**

umbrel@umbrel:/var/run $ sudo systemctl status docker.service  
[sudo] password for umbrel:  
● docker.service - Docker Application Container Engine  
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)  
Active: activating (auto-restart) (Result: exit-code) since Thu 2022-07-21 16:08:14 UTC; 1s ago  
Docs: [https://docs.docker.com](https://docs.docker.com)  
Process: 11295 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=2  
Main PID: 11295 (code=exited, status=2)

* * *

**Here is the journalctl -xe.**

## umbrel@umbrel:/var/run $ journalctl -xe Jul 21 16:16:03 umbrel dockerd[31831]: /go/src/github.com/docker/docker/vendor/github.com/spf13/cobra/command.go Jul 21 16:16:03 umbrel dockerd[31831]: [github.com/docker/docker/vendor/github.com/spf13/cobra.(\*Command).ExecuteC](http://github.com/docker/docker/vendor/github.com/spf13/cobra.(*Command).ExecuteC)(0x4000 Jul 21 16:16:03 umbrel dockerd[31831]: /go/src/github.com/docker/docker/vendor/github.com/spf13/cobra/command.go Jul 21 16:16:03 umbrel dockerd[31831]: [github.com/docker/docker/vendor/github.com/spf13/cobra.(\*Command).Execute(...)](http://github.com/docker/docker/vendor/github.com/spf13/cobra.(*Command).Execute(...)) Jul 21 16:16:03 umbrel dockerd[31831]: /go/src/github.com/docker/docker/vendor/github.com/spf13/cobra/command.go Jul 21 16:16:03 umbrel dockerd[31831]: main.main() Jul 21 16:16:03 umbrel dockerd[31831]: /go/src/github.com/docker/docker/cmd/dockerd/docker.go:97 +0x1b4 Jul 21 16:16:03 umbrel systemd[1]: docker.service: Main process exited, code=exited, status=2/INVALIDARGUMENT – Subject: Unit process exited – Defined-By: systemd – Support: [Debian -- User Support](https://www.debian.org/support)

## – An ExecStart= process belonging to unit docker.service has exited.

## – The process’ exit code is ‘exited’ and its exit status is 2. Jul 21 16:16:03 umbrel systemd[1]: docker.service: Failed with result ‘exit-code’. – Subject: Unit failed – Defined-By: systemd – Support: [Debian -- User Support](https://www.debian.org/support)

## – The unit docker.service has entered the ‘failed’ state with result ‘exit-code’. Jul 21 16:16:03 umbrel systemd[1]: Failed to start Docker Application Container Engine. – Subject: A start job for unit docker.service has failed – Defined-By: systemd – Support: [Debian -- User Support](https://www.debian.org/support)

## – A start job for unit docker.service has finished with a failure.

– The job identifier is 12539 and the job result is failed.

* * *

I admit I am out of my depth here, but it appears that the Docker Application Container Engine is the issue. I am just not sure how to troubleshoot from here. I appreciate any helpful posts, links, or advice. Thank you for your time and consideration.

_Jaes aka OpenWaterSwim_

---

<div class="post-metadata">

**Author:** ![Pierre](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/pierre/32/7178_2.png) [@Pierre](https://community.umbrel.com/u/Pierre)\
**Post date:** [July 26, 2022, 10:39am UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/2 "2022-07-26T10:39:58Z")

</div>

Hi  
I got the same issue and i’ve just solved it!  
I’ve first flashed the micro sd. But nothing changed.  
Then I followed this steps :

Step 1 - Enter using SSH into your Umbrel node:

Step 2 - stop Umbrel node with:

`cd umbrel`  
`sudo systemctl stop umbrel-startup`

Step 3 - clean / reconfigure the broken container:

`sudo rm .env` --\> got an error because .env did not existed. No probs  
`sudo ./scripts/configure`

Step 4 - apply latest Umbrel update (replace the version number with the latest):

`sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.0`

Restart your node:

UmbrelOS (RPi) use `sudo systemctl start umbrel-startup`

Worked fine for me! I hope it’s gonna help you  
Cheers  
Pierre

---

<div class="post-metadata">

**Author:** ![OpenWaterSwim](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/openwaterswim/32/2014_2.png) [@OpenWaterSwim](https://community.umbrel.com/u/OpenWaterSwim)\
**Post date:** [July 26, 2022, 7:52pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/3 "2022-07-26T19:52:43Z")

</div>

**Pierre** :

Thank you for your reply. I appreciate any and all suggestions as I feel like I have tried plenty. At least through all this troubleshooting, I learn with each new attempt to fix my issue. I have also been able to help others while learning, so this is all a plus as I believe I am then able to give back to the community.

When I get to step 3 and run the following command  
sudo .scripts/configure

I receive the error message regarding the Docker daemon.

* * *

umbrel@umbrel:~/umbrel $ sudo ./scripts/configure

# ====================================== =========== RECONFIGURING ============ ========= UMBREL (mainnet) ===========

Generating auth credentials

Generating Tor password

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.  
See ‘docker run --help’.

* * *

I tried the following to see if I could fix the Docker, but there still seems to be a problem with my docker-compose.yml file.

cd umbrel  
sudo systemctl stop docker.service  
sudo systemctl stop docker.socket  
sudo rm -rf /var/lib/docker/\* && sudo umount /var/lib/docker || true && sudo rm -rf /mnt/data/docker/\*  
sudo reboot

* * *

However, this likewise did not correct my issue. Thank you for your suggestion. We will figure it out.

---

<div class="post-metadata">

**Author:** ![supriseflash](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/supriseflash/32/2509_2.png) [@supriseflash](https://community.umbrel.com/u/supriseflash)\
**Post date:** [August 18, 2022, 6:53pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/4 "2022-08-18T18:53:56Z")

</div>

Merci Pierre. This helped fixed a separate issue I had with the dockers not being able to fully shut down and reboot.

---

<div class="post-metadata">

**Author:** ![sleepingsexton](https://avatars.discourse-cdn.com/v4/letter/s/7ea924/32.png) [@sleepingsexton](https://community.umbrel.com/u/sleepingsexton)\
**Post date:** [September 9, 2022, 2:08pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/5 "2022-09-09T14:08:48Z")

</div>

Also having the same issue. Did you figure it out?

---

<div class="post-metadata">

**Author:** ![suhask](https://avatars.discourse-cdn.com/v4/letter/s/bbe5ce/32.png) [@suhask](https://community.umbrel.com/u/suhask)\
**Post date:** [December 9, 2022, 10:07am UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/6 "2022-12-09T10:07:08Z")

</div>

I am also having the same issue. Did anyone figure this out yet?

---

<div class="post-metadata">

**Author:** ![Groove](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/groove/32/4509_2.png) [@Groove](https://community.umbrel.com/u/Groove)\
**Post date:** [August 11, 2023, 12:30pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/7 "2023-08-11T12:30:47Z")

</div>

hello, i am stuck here with this same issue…

---

<div class="post-metadata">

**Author:** ![smolgrrr](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/smolgrrr/32/2825_2.png) [@smolgrrr](https://community.umbrel.com/u/smolgrrr)\
**Post date:** [August 12, 2023, 2:25am UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/8 "2023-08-12T02:25:00Z")

</div>

Hi @Groove, have you tried the following, and if so could you please share your troubleshooting logs?

**Step 1 - Enter using SSH into your Umbrel node:**

**Step 2 - stop Umbrel node with:**

cd umbrel

sudo ./scripts/stop

**Step 3 - clean / reconfigure the broken container:**

sudo rm -f .env && sudo ./scripts/configure

**Step 4 - Restart your node:**

sudo ./scripts/start

> [@Official Umbrel Troubleshooting Guide and FAQ](https://community.umbrel.com/t/official-umbrel-troubleshooting-guide-and-faq/9873/1):
>
> If you are unable to access your Umbrel through a web browser, you can generate troubleshooting logs from the command line by following these steps:
> 
> 1. Connect to your Umbrel device by following the instructions in _How to SSH into Umbrel on a Raspberry Pi_ or by accessing a terminal on your Linux machine.
> 2. Run the following command. If you are on a Linux machine, you may need to replace `~` with the path to your installation directory, as described in _Troubleshooting on Linux_:`sudo ~/umbrel/scripts/debug`

Please share them from here [https://pastebin.com/](https://pastebin.com/)

---

<div class="post-metadata">

**Author:** ![Groove](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/groove/32/4509_2.png) [@Groove](https://community.umbrel.com/u/Groove)\
**Post date:** [August 14, 2023, 9:37pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/9 "2023-08-14T21:37:09Z")

</div>

# ===================== = Umbrel debug info =

## Umbrel version

0.5.0

## Memory usage

```
           total usada livre compart. buff/cache disponível

```

Mem.: 4,1G 1,8G 141M 167M 2,6G 2,3G  
Swap: 4,1G 610M 3,5G

total: 42,9%  
tor: 0%  
system: %  
mempool: 0%  
lndg: 0%  
lnd: 0%  
lightning: 0%  
electrs: 0%  
electrs: 0%  
bluewallet: 0%  
bitcoin: 0%  
bitcoin: 0%

## Memory monitor logs

3333 ? S 0:00 bash ./scripts/memory-monitor  
Memory monitor is already running  
2023-08-11 10:20:23 Warning memory usage at 91%  
2023-08-11 10:21:23 Warning memory usage at 93%  
2023-08-12 10:16:38 Memory monitor running!  
2023-08-12 11:23:51 Warning memory usage at 92%  
2023-08-12 11:24:52 Warning memory usage at 92%  
2023-08-12 11:25:52 Warning memory usage at 91%  
2023-08-12 12:24:00 Warning memory usage at 93%  
2023-08-12 12:32:02 Warning memory usage at 96%

## Filesystem information

Sist. Arq. Tam. Usado Disp. Uso% Montado em  
/dev/sda2 916G 654G 216G 76% /  
/dev/sda2 916G 654G 216G 76% /

## Karen logs

# 3924 bytes (3,9 kB, 3,8 KiB) copied, 0,0118845 s, 330 kB/s Creating encrypted tarball… backup/ backup/.padding backup/channel.backup Uploading backup… % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 5123 100 146 100 4977 31 1078 0:00:04 0:00:04 --:–:-- 1559 {“message”:“Successfully uploaded backup 1691752226465.tar.gz.pgp for backup ID 00eeacdf540898c21482f02811819f2c7367399f01b5610a4c192ef1944a81f7”}

# ====== Backup success =======

Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
Got signal:  
karen is getting triggered!  
Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
3321 ? S 0:00 bash ./karen  
3376 ? S 0:00 bash ./karen  
karen is already running  
Got signal:  
karen is getting triggered!  
Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
Got signal:  
karen is getting triggered!  
Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
3321 ? S 0:00 bash ./karen  
3376 ? S 0:00 bash ./karen  
karen is already running  
karen is running in /home/diogo/umbrel/events  
Got signal:  
karen is getting triggered!  
Got signal:  
karen is getting triggered!  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório  
./karen: linha 68: /home/diogo/umbrel/events/triggers/: É um diretório

## Docker containers

NAMES STATUS

## Umbrel logs

Attaching to

## Tor logs

Attaching to

## App logs

bitcoin

Attaching to

bluewallet

Attaching to

electrs

Attaching to

lightning

Attaching to

lndg

Attaching to

mempool

# Attaching to

# ==== Result ====

The debug script did not automatically detect any issues with your Umbrel.

---

<div class="post-metadata">

**Author:** ![Groove](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/groove/32/4509_2.png) [@Groove](https://community.umbrel.com/u/Groove)\
**Post date:** [August 14, 2023, 9:43pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/10 "2023-08-14T21:43:26Z")

</div>

![stopping](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/0/004ed976a7adf40807d94658fa2fbe8c0f958563.png)

---

<div class="post-metadata">

**Author:** ![smolgrrr](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/smolgrrr/32/2825_2.png) [@smolgrrr](https://community.umbrel.com/u/smolgrrr)\
**Post date:** [August 15, 2023, 11:13am UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/11 "2023-08-15T11:13:25Z")

</div>

It appears your Umbrel is not up-to-date- this may resolve the issue.

Try running the following

> sudo ~/umbrel/scripts/update/update --repo getumbrel/umbrel#v0.5.4

---

<div class="post-metadata">

**Author:** ![Frog](https://avatars.discourse-cdn.com/v4/letter/f/9fc29f/32.png) [@Frog](https://community.umbrel.com/u/Frog)\
**Post date:** [May 20, 2024, 6:18pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/12 "2024-05-20T18:18:00Z")

</div>

Hello, I have followed this with my node after an unsuccessful trial to replace my 5.0.4 with 1.1.0 on a new SD card.  
When I reverted back to the old card I had the container issue.  
The first step was the official support method restarting the container which didn’t help.

Then I followed the steps in his thread without completely understanding what I was doing. After the cleanup and upgrade, I ended with the start page of not not-configured node. Asking me to set up the new account. This is a complete disaster for me because I had a Bitcoin wallet, a Lightning node with 7 quite big channels and BTCPay server to receive Lightning invoices. Now I am afraid to move an inch in my troubleshooting/recovery not to lose everything.  
I do have seed, I do have ssh access to the node, I do have fresh channels backup, I have a backup of the most files I took before the disaster (/etc, /home ) and I believe most of the data remained intact on the node M2 drive. Only the configuration of the node has been wiped out by the steps from Pierre. Please help me and suggest the node recovery approach.

---

<div class="post-metadata">

**Author:** ![Frog](https://avatars.discourse-cdn.com/v4/letter/f/9fc29f/32.png) [@Frog](https://community.umbrel.com/u/Frog)\
**Post date:** [May 21, 2024, 9:28am UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/13 "2024-05-21T09:28:12Z")

</div>

I have reviewed the configure script which did the configuration reset. So I have a clue which files were updated.

# Remove intermediary files if they exist from any

# previous unclean configuration run

[[-f “$NGINX\_CONF\_FILE”]] && rm -f “$NGINX\_CONF\_FILE”  
[[-f “$TOR\_PROXY\_CONF\_FILE”]] && rm -f “$TOR\_PROXY\_CONF\_FILE”  
[[-f “$TOR\_SERVER\_CONF\_FILE”]] && rm -f “$TOR\_SERVER\_CONF\_FILE”  
[[-f “$ENV\_FILE”]] && rm -f “$ENV\_FILE”

# Copy template configs to intermediary configs

[[-f “./templates/nginx-sample.conf”]] && cp “./templates/nginx-sample.conf” “$NGINX\_CONF\_FILE”  
[[-f “./templates/torrc-proxy-sample”]] && cp “./templates/torrc-proxy-sample” “$TOR\_PROXY\_CONF\_FILE”  
[[-f “./templates/torrc-server-sample”]] && cp “./templates/torrc-server-sample” “$TOR\_SERVER\_CONF\_FILE”  
[[-f “./templates/.env-sample”]] && cp “./templates/.env-sample” “$ENV\_FILE”

So I am thinking of restoring .env file from the backup and restart. I will back up the current one as well. Any objections?  
Anything else to restore at the same time?  
I am super vigilant after my f\*ck up.

---

<div class="post-metadata">

**Author:** ![Frog](https://avatars.discourse-cdn.com/v4/letter/f/9fc29f/32.png) [@Frog](https://community.umbrel.com/u/Frog)\
**Post date:** [May 21, 2024, 12:00pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/14 "2024-05-21T12:00:47Z")

</div>

Finally, the node recovered, with no losses.  
I just needed to set the password for the Umbrel start page, which was scary and fresh install apps from the store. Bitcoin synchronized the last 5 missing blocks (must have been running well in the background) and Lightning remains configured. Good design of Umbrel!  
I will need to reconfigure nginx as BTC pay server is not responding over SSL.

I think I would need a test environment for these upgrades. Not as easy as described in the upgrade tutorial.  
I also can’t imagine losing data on the M2 drive. That would be a disaster with my skills and the recovery time needed to sync with the blockchain.

---

<div class="post-metadata">

**Author:** ![smolgrrr](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/smolgrrr/32/2825_2.png) [@smolgrrr](https://community.umbrel.com/u/smolgrrr)\
**Post date:** [May 21, 2024, 12:49pm UTC](https://community.umbrel.com/t/failed-to-start-docker-application-container-engine/8816/15 "2024-05-21T12:49:30Z")

</div>

Great to hear it was resolved!  
I’d suggest checking out [Cloudflared](https://apps.umbrel.com/app/cloudflared) for BTCPay.
