# Endless loop of log errors related to IPv6 in journalctl

**URL:** <https://community.umbrel.com/t/endless-loop-of-log-errors-related-to-ipv6-in-journalctl/17940>\
**Category:** Support and Troubleshooting\
**Created:** [June 18, 2024, 10:07pm UTC](https://community.umbrel.com/t/endless-loop-of-log-errors-related-to-ipv6-in-journalctl/17940 "2024-06-18T22:07:56Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![matrix\_stuff](https://avatars.discourse-cdn.com/v4/letter/m/3bc359/32.png) [@matrix\_stuff](https://community.umbrel.com/u/matrix_stuff)\
**Post date:** [June 18, 2024, 10:07pm UTC](https://community.umbrel.com/t/endless-loop-of-log-errors-related-to-ipv6-in-journalctl/17940/1 "2024-06-18T22:07:56Z")

</div>

What are these errors and how can I fix it?  
As far as I researched they may be related to NTP as discussed on the following post:  
[https://bbs.archlinux.org/viewtopic.php?id=110718](https://bbs.archlinux.org/viewtopic.php?id=110718)

But I don’t understand how exactly to resolve it in Umbrel.

The command I run is:

```auto
sudo journalctl -p 4 -x -b

```

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/f/f5703295e3d7fa32e118efeadfc05d53ae861f54.png)

And this is the ntpsec service. Not sure what I should change.

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/a/ad0db6b46e4f96fab0d1fee2feab5b86e864ad35.png)

The ntp.conf file:

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/c/c8a7d454693e4e5484acc193fa6058f6b650594d.png)

---

<div class="post-metadata">

**Author:** ![matrix\_stuff](https://avatars.discourse-cdn.com/v4/letter/m/3bc359/32.png) [@matrix\_stuff](https://community.umbrel.com/u/matrix_stuff)\
**Post date:** [June 19, 2024, 7:09pm UTC](https://community.umbrel.com/t/endless-loop-of-log-errors-related-to-ipv6-in-journalctl/17940/2 "2024-06-19T19:09:23Z")

</div>

Here’s how I fixed it:

```auto
sudo nano /usr/libexec/ntpsec/ntp-systemd-wrapper

```

Then modify the line in the middle to be:

```auto
NTPD_OPTS="$NTPD_OPTS -4 -u ntpsec:ntpsec"

```

The -4 forces the service to use only IPv4  
Then to reload the change and then restart the service:

```auto
systemctl daemon-reload
systemctl restart ntpsec

```

After 30 minutes, check logs to verify the errors are gone:

```auto
sudo journalctl -p 4 | less +G

```

You can also verify that the service now includes -4 in the options with this command:

```auto
systemctl status ntpsec.service

```

If anyone from Umbrel sees this, this change to the file should be built-in into Umbrel when installed fresh, because it’s a bug.
