# Electrs stuck - reading app logs (and identifying docker processes)

**URL:** <https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373>\
**Category:** Support and Troubleshooting\
**Created:** [September 8, 2022, 7:17pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373 "2022-09-08T19:17:34Z")\
**Posts on this page:** 10\
**Page:** 2

<div class="post-metadata">

**Author:** ![vhornik](https://avatars.discourse-cdn.com/v4/letter/v/c77e96/32.png) [@vhornik](https://community.umbrel.com/u/vhornik)\
**Post date:** [November 23, 2022, 3:36pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/21 "2022-11-23T15:36:25Z")

</div>

This info finally helped me! Thanks!!  
I had maxuploadtarget=500 in bitcoin.conf, this seem to cause the same trouble, after removing that electrs runs and is syncing

---

<div class="post-metadata">

**Author:** ![lonerangir](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/lonerangir/32/3253_2.png) [@lonerangir](https://community.umbrel.com/u/lonerangir)\
**Post date:** [November 23, 2022, 4:12pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/22 "2022-11-23T16:12:35Z")

</div>

Yes, it seems quite odd that there is not an external connection vs internal connection limit.

---

<div class="post-metadata">

**Author:** ![DarthDire](https://avatars.discourse-cdn.com/v4/letter/d/cab0a1/32.png) [@DarthDire](https://community.umbrel.com/u/DarthDire)\
**Post date:** [January 26, 2023, 4:25pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/23 "2023-01-26T16:25:35Z")

</div>

I have the same issue. Has there been any fix / update for this problem?

---

<div class="post-metadata">

**Author:** ![premie](https://avatars.discourse-cdn.com/v4/letter/p/f19dbf/32.png) [@premie](https://community.umbrel.com/u/premie)\
**Post date:** [February 13, 2023, 7:28am UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/24 "2023-02-13T07:28:35Z")

</div>

same problem here hmmmm

---

<div class="post-metadata">

**Author:** ![CloudSeeder](https://avatars.discourse-cdn.com/v4/letter/c/f07891/32.png) [@CloudSeeder](https://community.umbrel.com/u/CloudSeeder)\
**Post date:** [February 24, 2023, 10:04pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/25 "2023-02-24T22:04:25Z")

</div>

Same problem here. Don’t seem to find fixes but the number of users is adding up.

---

<div class="post-metadata">

**Author:** ![LAN1](https://avatars.discourse-cdn.com/v4/letter/l/b5a626/32.png) [@LAN1](https://community.umbrel.com/u/LAN1)\
**Post date:** [March 20, 2023, 5:22pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/26 "2023-03-20T17:22:16Z")

</div>

Same here

---

<div class="post-metadata">

**Author:** ![LAN1](https://avatars.discourse-cdn.com/v4/letter/l/b5a626/32.png) [@LAN1](https://community.umbrel.com/u/LAN1)\
**Post date:** [March 20, 2023, 5:29pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/27 "2023-03-20T17:29:25Z")

</div>

In my case after 6 hours of Electrs synchronization with the message “Waiting for Bitcoin Node to finish syncing…” the only files that are generated on disk are log files (one every minute) in app-data/electrs/data/electrs/db/bitcoin. No other files or disk space used

---

<div class="post-metadata">

**Author:** ![LAN1](https://avatars.discourse-cdn.com/v4/letter/l/b5a626/32.png) [@LAN1](https://community.umbrel.com/u/LAN1)\
**Post date:** [March 20, 2023, 7:00pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/29 "2023-03-20T19:00:47Z")

</div>

> [@Louie](#):
>
> ```auto
> electrs_1 | Caused by:
> electrs_1 | 0: failed to open bitcoind cookie file: /data/.bitcoin/.cookie
> electrs_1 | 1: No such file or directory (os error 2)
> 
> ```
> 
> I’ve tried creating the .cookie file with USER:PASS inside (replaced values) but still no luck.

Hi, in my case I create the file .cookie and now is:  
electrs\_1 | Caused by:  
electrs\_1 | failed to parse bitcoind cookie - missing ‘:’ separator

So now he is trying to read the file but  
I don’t know what to write inside the cookie file  
Thanks.

---

<div class="post-metadata">

**Author:** ![satsfaction](https://avatars.discourse-cdn.com/v4/letter/s/a3d4f5/32.png) [@satsfaction](https://community.umbrel.com/u/satsfaction)\
**Post date:** [March 30, 2023, 5:27pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/30 "2023-03-30T17:27:49Z")

</div>

I had this same issue of Electrs not synchronizing. I’m not sure if this is the best solution, but deleting the bitcoin.conf file worked for me.  
sudo rm ~/umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf  
It took 10-12 hours to sync after that.

---

<div class="post-metadata">

**Author:** ![BCg0](https://avatars.discourse-cdn.com/v4/letter/b/958977/32.png) [@BCg0](https://community.umbrel.com/u/BCg0)\
**Post date:** [April 16, 2023, 10:48pm UTC](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373/31 "2023-04-16T22:48:58Z")

</div>

Ok guys I finally got the Umbrel Electrum Server (Electrs Vers. 0.9.10) running on the Raspi 4 with 8GB. Who still needs support, here is my procedure …

For a fast processing I use the following software:

- putty (portable) for the SSH connection from a PC to the Raspi
- FileZilla (portable) for the transfer of files between PC and Raspi  
If you want you can edit the files with nano or similar via the SSH connection.

Installed apps:

- Bitcoin Node (24.0.1)
- Lightning Node (0.15.5-beta)
- BlueWallet
- Electrs (0.9.10) --\> I uninstalled and installed again
- LNDg
- Ride the Lightning
- ThunderHub

Quick guide:

1. check if the bitcoin.conf file exists in the directory and comment out the following entries.  
maxconnections=X (the X stands for an arbitrary number)  
rpcuser=umbrel  
rpcpassword=[password was here]  
If not present create with a default entry e.g.  
**# Load additional configuration file, relative to the data directory.**

2. error checking in app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600

3. reboot the raspi now … important!!!

4. check the performance with htop

5. check again for errors in the app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600  
If there are still errors I can’t help and you can abort, sorry.

6. search for the following entries  
app\_proxy\_1 | Electrs is now ready…  
app\_proxy\_1 | Listening on port: xxxxx  
and  
app\_proxy\_1 | Validating token: xxxxxxxxx …  
and  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Loading block index…  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Verifying blocks…  
and very important —\>\>\>  
electrs\_1 | [Date INFO electrs::db] starting config compaction  
electrs\_1 | [Date INFO electrs::db] starting headers compaction  
electrs\_1 | [Date INFO electrs::db] starting txid compaction  
electrs\_1 | [Date INFO electrs::db] starting funding compaction  
electrs\_1 | [date INFO electrs::db] starting spending compaction

7. now be patient for about 5 hours.  
then error check again in app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600

now search for  
electrs\_1 [date INFO electrs::db] finished full compaction

1. finished and have fun

Detailed instructions:

1. check if the bitcoin.conf file exists in the directory  
/home/umbrel/umbrel/app-data/bitcoin/data/bitcoin

If the bitcoin.conf file exists edit it, if not create it with a default entry e.g.  
**# Load additional configuration file, relative to the data directory.**

Explanation: for my 1.5 year old Umbrel environment this file is needed to automatically create the other important file called .cookie.  
I believe that in the .cookie file the last block value of the service/app Bitcoin node is written. This block value is read and processed by the Electrum server.

- Open bitcoin.conf file and check if this entry is present  
**maxconnections=X**  
(the X stands for an arbitrary number)  
Comment the entry out with #, it must look like this  
**# maxconnections=X**

- open bitcoin.conf file and check if this entry is present  
**rpcuser=umbrel**  
**rpcpassword=[password was here]**  
Comment both entries out with #, it must look like this  
**# rpcuser=umbrel**  
**# rpcpassword=[password was here]**

These three changes (commenting out) were enough in my environment to stop the Elecrtum server from displaying errors like this.

Error: electrs failed  
electrs\_1 |  
electrs\_1 | Caused by:  
electrs\_1 | receiving on an empty and disconnected channel

or

electrs\_1 | Error: electrs failed  
electrs\_1 |  
electrs\_1 | Caused by:  
electrs\_1 | 0: failed to open bitcoind cookie file: /data/.bitcoin/.cookie  
electrs\_1 | 1: No such file or directory (os error 2)

1. error check in app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600  
If there are still errors in there no problem!!!

2. reboot the Raspi now

3. open a new SSH window and type htop.  
You will see the current performance consumption.  
Sorted by PERCENT\_CPU  
A big consumption at electrs and tor is shown, no probelm!

4. again error check in the app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600  
Explanation: after the reboot the bitcoin.conf file was reread and the .cookie file was created in the directory  
/home/umbrel/umbrel/app-data/bitcoin/data/bitcoin  
If there are still errors I can’t help you and you can abort, sorry.

5. search for the following entries  
app\_proxy\_1 | Electrs is now ready…  
app\_proxy\_1 | Listening on port: xxxxx  
and  
app\_proxy\_1 | Validating token: xxxxxxxxx …  
and  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Loading block index…  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Loading block index…  
and  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Loading block index…  
electrs\_1 | [Date INFO electrs::daemon] waiting for RPC warmup: Verifying blocks…  
and very important —\>\>\>  
electrs\_1 | [Date INFO electrs::db] starting config compaction  
electrs\_1 | [Date INFO electrs::db] starting headers compaction  
electrs\_1 | [Date INFO electrs::db] starting txid compaction  
electrs\_1 | [Date INFO electrs::db] starting funding compaction  
electrs\_1 | [date INFO electrs::db] starting spending compaction

6. now be patient for about 5 hrs.  
then error check again in app compose logs  
sudo ~/umbrel/scripts/app compose electrs logs --tail=600

now search for  
electrs\_1 [date INFO electrs::db] finished full compaction

1. thats it finished and have fun

[Previous page](https://community.umbrel.com/t/electrs-stuck-reading-app-logs-and-identifying-docker-processes/9373.md?page=1)
