# Booting problem: System service failed

**URL:** <https://community.umbrel.com/t/booting-problem-system-service-failed/4687>\
**Category:** Support and Troubleshooting\
**Created:** [November 14, 2021, 8:58pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687 "2021-11-14T20:58:15Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 14, 2021, 8:58pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/1 "2021-11-14T20:58:15Z")

</div>

Hi everyone. After upgrade to 0.4.5 I’ve got an error, after that Umbrel can’t boot up.

Here is my logs. Please help me

# umbrel@umbrel:~/umbrel $ ~/umbrel/scripts/debug --upload

# = Umbrel debug info =

## Umbrel version

0.4.4

## Flashed OS version

v0.4.5

## Raspberry Pi Model

Revision : d03114  
Serial : 1000000088a27983  
Model : Raspberry Pi 4 Model B Rev 1.4

## Firmware

Sep 30 2021 19:21:03  
Copyright © 2012 Broadcom  
version 51215b4f6e3966401ecd99652a35cf1c25069113 (clean) (release) (start)

## Temperature

temp=47.2’C

## Throttling

throttled=0x0

## Memory usage

```
          total used free shared buff/cache available

```

Mem: 7.8G 140M 7.4G 8.0M 293M 7.6G  
Swap: 4.1G 0B 4.1G

total: 1.8%  
system: 1.8%  
tor: 0%  
lnd: 0%  
electrs: 0%  
bitcoin: 0%

## Memory monitor logs

2021-10-26 01:41:01 Memory monitor running!  
2021-10-26 01:41:15 Memory monitor running!  
2021-10-26 01:41:30 Memory monitor running!  
2021-10-26 01:41:44 Memory monitor running!  
2021-10-26 01:41:58 Memory monitor running!  
2021-10-26 01:42:13 Memory monitor running!  
2021-10-26 01:42:27 Memory monitor running!  
2021-10-26 01:42:41 Memory monitor running!  
2021-10-26 01:42:56 Memory monitor running!  
2021-10-26 01:30:54 Memory monitor running!

## Filesystem information

Filesystem Size Used Avail Use% Mounted on  
/dev/root 59G 3.0G 54G 6% /  
/dev/sda1 916G 32G 838G 4% /home/umbrel/umbrel

## Startup service logs

– Logs begin at Sun 2021-11-14 20:47:59 UTC, end at Sun 2021-11-14 20:50:47 UTC. –  
Nov 14 20:48:17 umbrel systemd[1]: Dependency failed for Umbrel Startup Service.  
Nov 14 20:48:17 umbrel systemd[1]: umbrel-startup.service: Job umbrel-startup.service/start failed with result ‘dependency’.

## External storage service logs

– Logs begin at Sun 2021-11-14 20:47:59 UTC, end at Sun 2021-11-14 20:50:47 UTC. –  
Nov 14 20:48:04 umbrel systemd[1]: Starting External Storage Mounter…  
Nov 14 20:48:04 umbrel external storage mounter[488]: Running external storage mount script…  
Nov 14 20:48:04 umbrel external storage mounter[488]: Found device “CT1000MX 500SSD1”  
Nov 14 20:48:04 umbrel external storage mounter[488]: Blacklisting USB device IDs against UAS driver…  
Nov 14 20:48:04 umbrel external storage mounter[488]: Rebinding USB drivers…  
Nov 14 20:48:04 umbrel external storage mounter[488]: Checking USB devices are back…  
Nov 14 20:48:04 umbrel external storage mounter[488]: Waiting for USB devices…  
Nov 14 20:48:05 umbrel external storage mounter[488]: Waiting for USB devices…  
Nov 14 20:48:06 umbrel external storage mounter[488]: Checking if the device is ext4…  
Nov 14 20:48:07 umbrel external storage mounter[488]: Yes, it is ext4  
Nov 14 20:48:07 umbrel external storage mounter[488]: Checking if device contains an Umbrel install…  
Nov 14 20:48:07 umbrel external storage mounter[488]: Yes, it contains an Umbrel install  
Nov 14 20:48:07 umbrel external storage mounter[488]: Bind mounting external storage over local Umbrel installation…  
Nov 14 20:48:07 umbrel external storage mounter[488]: Bind mounting external storage over local Docker data dir…  
Nov 14 20:48:07 umbrel external storage mounter[488]: Bind mounting external storage to /swap  
Nov 14 20:48:07 umbrel external storage mounter[488]: Bind mounting SD card root at /sd-card…  
Nov 14 20:48:07 umbrel external storage mounter[488]: Checking Umbrel root is now on external storage…  
Nov 14 20:48:08 umbrel external storage mounter[488]: Checking /var/lib/docker is now on external storage…  
Nov 14 20:48:08 umbrel external storage mounter[488]: Checking /swap is now on external storage…  
Nov 14 20:48:08 umbrel external storage mounter[488]: Setting up swapfile  
Nov 14 20:48:08 umbrel external storage mounter[488]: Setting up swapspace version 1, size = 4 GiB (4294963200 bytes)  
Nov 14 20:48:08 umbrel external storage mounter[488]: no label, UUID=0a0a8acc-7b31-4995-aa4d-d67994bff5b0  
Nov 14 20:48:08 umbrel external storage mounter[488]: Checking SD Card root is bind mounted at /sd-root…  
Nov 14 20:48:08 umbrel external storage mounter[488]: Starting external drive mount monitor…  
Nov 14 20:48:08 umbrel external storage mounter[488]: Mount script completed successfully!  
Nov 14 20:48:08 umbrel systemd[1]: Started External Storage Mounter.

## External storage SD card update service logs

– Logs begin at Sun 2021-11-14 20:47:59 UTC, end at Sun 2021-11-14 20:50:47 UTC. –  
Nov 14 20:48:16 umbrel systemd[1]: Starting External Storage SDcard Updater…  
Nov 14 20:48:16 umbrel external storage updater[999]: Checking if SD card Umbrel is newer than external storage…  
Nov 14 20:48:17 umbrel external storage updater[999]: Yes, SD version is newer.  
Nov 14 20:48:17 umbrel external storage updater[999]: Checking if the external storage version “0.4.4” satisfies update requirement “\>=0.2.1”…  
Nov 14 20:48:17 umbrel external storage updater[999]: Yes, it does, attempting an automatic update…  
Nov 14 20:48:17 umbrel external storage updater[999]: =======================================  
Nov 14 20:48:17 umbrel external storage updater[999]: =============== UPDATE ================  
Nov 14 20:48:17 umbrel external storage updater[999]: =======================================  
Nov 14 20:48:17 umbrel external storage updater[999]: ========== Stage: Download ============  
Nov 14 20:48:17 umbrel external storage updater[999]: =======================================  
Nov 14 20:48:17 umbrel external storage updater[999]: An update is already in progress. Exiting now.  
Nov 14 20:48:17 umbrel systemd[1]: umbrel-external-storage-sdcard-update.service: Main process exited, code=exited, status=2/INVALIDARGUMENT  
Nov 14 20:48:17 umbrel systemd[1]: umbrel-external-storage-sdcard-update.service: Failed with result ‘exit-code’.  
Nov 14 20:48:17 umbrel systemd[1]: Failed to start External Storage SDcard Updater.

## Karen logs

449 ? R 0:00 bash ./karen  
450 ? R 0:00 bash ./karen  
karen is already running  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events  
karen is running in /home/umbrel/umbrel/events

## Docker containers

NAMES STATUS

## Bitcoin Core logs

Attaching to bitcoin  
bitcoin | 2021-10-26T02:51:58Z init message: Loading block index…  
bitcoin | 2021-10-26T02:51:58Z Switching active chainstate to Chainstate [ibd] @ height -1 (null)  
bitcoin | 2021-10-26T02:51:58Z Opening LevelDB in /data/.bitcoin/blocks/index  
bitcoin | 2021-10-26T02:51:58Z Opened LevelDB successfully  
bitcoin | 2021-10-26T02:51:58Z Using obfuscation key for /data/.bitcoin/blocks/index: 0000000000000000  
bitcoin | 2021-10-26T02:52:11Z LoadBlockIndexDB: last block file = 143  
bitcoin | 2021-10-26T02:52:11Z LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=470, size=119167307, heights=302411…302966, time=2014-05-24…2014-05-28)  
bitcoin | 2021-10-26T02:52:11Z Checking all blk files are present…  
bitcoin | 2021-10-26T02:52:11Z Opening LevelDB in /data/.bitcoin/chainstate  
bitcoin | 2021-10-26T02:52:11Z Opened LevelDB successfully  
bitcoin | 2021-10-26T02:52:13Z Using obfuscation key for /data/.bitcoin/chainstate: 4c1d6874a18d031e  
bitcoin | 2021-10-26T02:52:14Z Loaded best chain: hashBestChain=00000000000000002033b076e13e955da9932627aa7d4749b2f2a1d2ffe69e35 height=302554 date=2014-05-25T12:08:11Z progress=0.058248  
bitcoin | 2021-10-26T02:52:14Z init message: Verifying blocks…  
bitcoin | 2021-10-26T02:52:14Z Verifying last 6 blocks at level 3  
bitcoin | 2021-10-26T02:52:14Z [0%]…LevelDB read failure: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/003554.ldb  
bitcoin | 2021-10-26T02:52:20Z Fatal LevelDB error: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/003554.ldb  
bitcoin | 2021-10-26T02:52:20Z You can use -debug=leveldb to get more complete diagnostic messages  
bitcoin | 2021-10-26T02:52:20Z Fatal LevelDB error: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/003554.ldb  
bitcoin | 2021-10-26T02:52:20Z : Error opening block database.  
bitcoin | Please restart with -reindex or -reindex-chainstate to recover.  
bitcoin | : Error opening block database.  
bitcoin | Please restart with -reindex or -reindex-chainstate to recover.  
bitcoin | 2021-10-26T02:52:20Z Aborted block database rebuild. Exiting.  
bitcoin | 2021-10-26T02:52:20Z Shutdown: In progress…  
bitcoin | 2021-10-26T02:52:20Z scheduler thread exit  
bitcoin | 2021-10-26T02:52:20Z FlushStateToDisk: write coins cache to disk (0 coins, 0kB) started  
bitcoin | 2021-10-26T02:52:20Z FlushStateToDisk: write coins cache to disk (0 coins, 0kB) completed (0.01s)  
bitcoin | 2021-10-26T02:52:20Z FlushStateToDisk: write coins cache to disk (0 coins, 0kB) started  
bitcoin | 2021-10-26T02:52:20Z FlushStateToDisk: write coins cache to disk (0 coins, 0kB) completed (0.00s)  
bitcoin | 2021-10-26T02:52:22Z Shutdown: done

## LND logs

Attaching to lnd  
lnd | 2021-10-26 02:47:28.595 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info  
lnd | 2021-10-26 02:47:28.595 [INF] LTND: Active chain: Bitcoin (network=mainnet)  
lnd | 2021-10-26 02:47:29.050 [ERR] LTND: unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:47:29.050 [INF] LTND: Shutdown complete  
lnd |  
lnd | unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:48:30.157 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info  
lnd | 2021-10-26 02:48:30.157 [INF] LTND: Active chain: Bitcoin (network=mainnet)  
lnd | 2021-10-26 02:48:30.518 [ERR] LTND: unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:48:30.519 [INF] LTND: Shutdown complete  
lnd |  
lnd | unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:49:31.638 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info  
lnd | 2021-10-26 02:49:31.638 [INF] LTND: Active chain: Bitcoin (network=mainnet)  
lnd | 2021-10-26 02:49:32.011 [ERR] LTND: unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:49:32.012 [INF] LTND: Shutdown complete  
lnd |  
lnd | unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:50:33.462 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info  
lnd | 2021-10-26 02:50:33.462 [INF] LTND: Active chain: Bitcoin (network=mainnet)  
lnd | 2021-10-26 02:50:33.860 [ERR] LTND: unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:50:33.860 [INF] LTND: Shutdown complete  
lnd |  
lnd | unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:51:35.335 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info  
lnd | 2021-10-26 02:51:35.336 [INF] LTND: Active chain: Bitcoin (network=mainnet)  
lnd | 2021-10-26 02:51:35.686 [ERR] LTND: unable to initialize neutrino backend: unable to create neutrino light client: EOF  
lnd | 2021-10-26 02:51:35.687 [INF] LTND: Shutdown complete  
lnd |  
lnd | unable to initialize neutrino backend: unable to create neutrino light client: EOF

## Tor logs

# Attaching to tor tor | Oct 26 01:30:54.000 [warn] Bug: tor(log\_backtrace\_impl+0x68) [0x5563f7bc20] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(tor\_bug\_occurred\_+0x158) [0x5563f86f50] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(+0x68bb0) [0x5563ef8bb0] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(microdesc\_cache\_reload+0xcc) [0x5563efb24c] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(get\_microdesc\_cache+0x58) [0x5563efb340] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(nodelist\_set\_consensus+0x438) [0x5563f08de0] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(networkstatus\_set\_current\_consensus+0x988) [0x5563f01048] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(+0x71324) [0x5563f01324] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(router\_reload\_consensus\_networkstatus+0x58) [0x5563f013f0] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(run\_tor\_main\_loop+0x90) [0x5563ef1820] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(tor\_run\_main+0xd4) [0x5563ef1c4c] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(tor\_main+0x48) [0x5563ef05a8] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(main+0x24) [0x5563ef00d4] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: /lib/aarch64-linux-gnu/libc.so.6(\_\_libc\_start\_main+0xe4) [0x7fa10c9d24] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] Bug: tor(+0x60130) [0x5563ef0130] (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] warn\_if\_nul\_found(): Bug: Found unexpected NUL while reading microdesc journal, offset 0at position 1040676/1044480. (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] warn\_if\_nul\_found(): Bug: surrounding string: 3779646A49322B4B664B396F6174450A00000000000000000000000000000000 (on Tor 0.4.5.7 ) tor | Oct 26 01:30:54.000 [warn] parse error: internal NUL character. tor | Oct 26 01:30:54.000 [warn] Unparseable microdescriptor found in journal tor | Oct 26 01:30:55.000 [notice] Starting with guard context “default” tor | Oct 26 01:30:56.000 [notice] Bootstrapped 5% (conn): Connecting to a relay tor | Oct 26 01:30:56.000 [notice] Bootstrapped 10% (conn\_done): Connected to a relay tor | Oct 26 01:30:56.000 [notice] Bootstrapped 14% (handshake): Handshaking with a relay tor | Oct 26 01:30:57.000 [notice] Bootstrapped 15% (handshake\_done): Handshake with a relay done tor | Oct 26 01:30:57.000 [notice] Bootstrapped 75% (enough\_dirinfo): Loaded enough directory info to build circuits tor | Oct 26 01:30:57.000 [notice] Bootstrapped 90% (ap\_handshake\_done): Handshake finished with a relay to build circuits tor | Oct 26 01:30:57.000 [notice] Bootstrapped 95% (circuit\_create): Establishing a Tor circuit tor | Oct 26 01:44:04.000 [notice] Your system clock just jumped 785 seconds forward; assuming established circuits no longer work. tor | Oct 26 01:44:07.000 [notice] Bootstrapped 100% (done): Done tor | Oct 26 01:44:31.000 [notice] Guard redsox ($E0A3471C24C9021CC58FBF774203046FD2BC893F) is failing more circuits than usual. Most likely this means the Tor network is overloaded. Success counts are 165/236. Use counts are 85/85. 166 circuits completed, 0 were unusable, 1 collapsed, and 6 timed out. For reference, your timeout cutoff is 4560 seconds.

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 14, 2021, 10:05pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/2 "2021-11-14T22:05:37Z")

</div>

> [@vmo](#):
>
> bitcoin | 2021-10-26T02:52:14Z [0%]…LevelDB read failure: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/003554.ldb  
> bitcoin | 2021-10-26T02:52:20Z Fatal LevelDB error: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/003554.ldb

Did you read your own logs?  
Are pretty clear. You have corrupted data.  
Solution? re.index or wipe blocks and sync again

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 15, 2021, 1:08am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/3 "2021-11-15T01:08:05Z")

</div>

> [@DarthCoin](#):
>
> Solution? re.index or wipe blocks and sync again

How I can do that?

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 15, 2021, 1:08am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/4 "2021-11-15T01:08:57Z")

</div>

> [@Umbrel Troubleshooting Guide](http://community.umbrel.com/t/umbrel-troubleshooting-guide/3632/):
>
> Edit by moderators The new, official troubleshooting guide can be found here: Huge thanks to DarthCoin for writing and maintaining the previous community version of the guide.

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 15, 2021, 1:29am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/5 "2021-11-15T01:29:33Z")

</div>

Which exactly point is about re.index or wipe blocks?

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 15, 2021, 1:37am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/6 "2021-11-15T01:37:49Z")

</div>

Edit bitcoin.conf and add reindex=1  
Let the node to start slowly doing its job.  
Check the bitcoin logs with  
SSH into umbrel  
cd umbrel  
docker-compose logs -f bitcoin

this will show you in real time what is doing.  
Have patience, can take several days.  
When you see it finished, will also take more hours for electrs to reindex the blocks.  
When is done, stop the umbrel scripts and remove that reindex line.  
Start umbrel. done

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 15, 2021, 1:44am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/7 "2021-11-15T01:44:51Z")

</div>

> [@DarthCoin](#):
>
> When is done, stop the umbrel scripts and remove that reindex line.

Thank you! It’s very complete instruction to reindex. And how I can wipe it? Maybe just wipe my ssd and make a new partition NTFS?

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 15, 2021, 1:59am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/8 "2021-11-15T01:59:19Z")

</div>

Nooo, never format NTFS.  
To be sure that the disk will be OK, yes, is good to start over with a format, but not NTFS.  
Umbrel is using ext4 format.  
So just go and delete the partition but not create a new one. Umbrel install will do it itself in its format type in the process.  
Just start over with a new installation as you did first time. Also wiping the mSD.  
New wallet seed, new instance, fresh.  
But remember, only if you have NO funds at all in that node.

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 15, 2021, 2:35am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/9 "2021-11-15T02:35:46Z")

</div>

> [@DarthCoin](#):
>
> wiping the mSD

Wiped SSD, wiped mSD, but umbrel.local just showing me that:

![Screenshot from 2021-11-14 20-35-12](https://canada1.discourse-cdn.com/flex030/uploads/getumbrel/original/2X/2/2a9e88a7b89d811a91274c6adfd30a3ad4fb72d1.png)

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 15, 2021, 8:33am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/10 "2021-11-15T08:33:25Z")

</div>

So no screen with setup user/pwd, save seed, nothing?  
Damn, that means you have serious trouble with that SSD. Time to replace it.  
Or check if your power source is original and OK. If the drive do not have enough power can get rekt.  
Also USB cables/case can cause damage or bad connection to the drive.

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 17, 2021, 5:01pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/11 "2021-11-17T17:01:29Z")

</div>

> [@DarthCoin](#):
>
> So no screen with setup user/pwd, save seed, nothing?

Nothing. Now I’m seeing " **Error: System service failed**"

# umbrel@umbrel:~ $ ~/umbrel/scripts/debug --upload

# = Umbrel debug info =

## Umbrel version

0.4.7

## Flashed OS version

v0.4.7

## Raspberry Pi Model

Revision : d03114  
Serial : 1000000088a27983  
Model : Raspberry Pi 4 Model B Rev 1.4

## Firmware

Oct 29 2021 10:47:33  
Copyright (c) 2012 Broadcom  
version b8a114e5a9877e91ca8f26d1a5ce904b2ad3cf13 (clean) (release) (start)

## Temperature

temp=48.2’C

## Throttling

throttled=0x0

## Memory usage

```
          total used free shared buff/cache available

```

Mem: 7.8G 128M 7.1G 8.0M 586M 7.6G  
Swap: 0B 0B 0B

total: 1.6%  
system: 1.6%  
tor: 0%  
lnd: 0%  
electrs: 0%  
bitcoin: 0%

## Memory monitor logs

tail: cannot open ‘/home/umbrel/umbrel/scripts/../logs/memory-monitor.log’ for reading: No such file or directory

## Filesystem information

Filesystem Size Used Avail Use% Mounted on  
/dev/root 59G 3.0G 54G 6% /  
/dev/root 59G 3.0G 54G 6% /

## Startup service logs

– Logs begin at Mon 2021-11-15 06:17:01 UTC, end at Wed 2021-11-17 17:00:12 UTC. –  
Nov 17 16:08:00 umbrel systemd[1]: Dependency failed for Umbrel Startup Service.  
Nov 17 16:08:00 umbrel systemd[1]: umbrel-startup.service: Job umbrel-startup.service/start failed with result ‘dependency’.

## External storage service logs

Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/9a10e0dcf646369d825273e2180109a51a93fdeec161a995072c1d5d0079a5cb’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/9e585f25f5988cb1f7e62c09a7fbf33ce0a526ae03cfb93292a35d8e2b427443’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/9f1aeac23927685ececfaf1b653b34d638db37d5b59dc09876dff9958481063c’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/a19cd352fa8207b38386b85b4047a3fb04c7a34528f9d3c340aca379280b538f’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/a3a4d858537faf87abde875319028b1138bac26d5a69e57fb0ea3b40b9aa7a2a’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/aa83cc4ec46773c1956f9c13e516577a82aaa87993ad816cc02a1dc85b81af89’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/ab68f524f9ac12f47ea3af71e0db2b80111fdda4fed7b8ef10e6e81d19ca5805’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/bff10f743391b8d007d4d5fcce424e2a36579d6e76e7060a96d7f1dd24e94d13’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/c991b5432313f0c926dd0ea68f89899f515bd90ad3d579f62815c97c35364511’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/d04e87dc6571f3cf2320effa090bd68007d5a56b65a0ff909aac19c0817c3dc1’: Read-only file system  
Nov 17 16:08:00 umbrel systemd[1]: umbrel-external-storage.service: Failed with result ‘exit-code’.  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/d16e0cd0a20d87685eaa1d2f355850e9e2fe9fcd439cfd385e7420a330fa77da’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/d30076602e2e8b394055156a55a519af99f6309b12c7fa69df63c63cd403dd40’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/d82cbc087421e51431a510e394c5d783c2dc6af25361f77e9b3531cec493aed2’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/e090c080beee655b2bdd6946d44def85e7e7030a45f9d46a9002170f0e73fbf3’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/ebca6fdd5c258e474a390b1f228f1530e7ca1fad9e08c496773697c803b90144’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/eeac2130b812a686288113cb1d447a2641fe64942f1cd1dafdaafedaf05d8dfc’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/f87a0c38d1609f19f4cca1775de11f1e7ca41fedb54b9840a1f959d7cc56fb64’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/f9e26e50a99b7f1be25e6a8e0102eb29fa0fd345e6b427c2826775d2490c3fae’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/fc5ad4c50e60459ec41100e33ec374f9353a8278fc2cca72c72928bf8a33e98e’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/overlay2/l’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: preserving times for ‘/mnt/data/docker/overlay2’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/plugins’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/swarm’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/trust’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/volumes’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/tmp’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: cannot create directory ‘/mnt/data/docker/runtimes’: Read-only file system  
Nov 17 16:08:00 umbrel external storage mounter[485]: cp: preserving times for ‘/mnt/data/docker’: Read-only file system  
Nov 17 16:08:00 umbrel systemd[1]: Failed to start External Storage Mounter.

## External storage SD card update service logs

– Logs begin at Mon 2021-11-15 06:17:01 UTC, end at Wed 2021-11-17 17:00:12 UTC. –  
Nov 17 16:08:00 umbrel systemd[1]: Dependency failed for External Storage SDcard Updater.  
Nov 17 16:08:00 umbrel systemd[1]: umbrel-external-storage-sdcard-update.service: Job umbrel-external-storage-sdcard-update.service/start failed with result ‘dependency’.

## Karen logs

tail: cannot open ‘logs/karen.log’ for reading: No such file or directory

## Docker containers

NAMES STATUS

## Umbrel logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor.ports contains an invalid type, it should be a number, or an object  
services.bitcoin.ports contains an invalid type, it should be a number, or an object  
services.electrs.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

## Bitcoin Core logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor.ports contains an invalid type, it should be a number, or an object  
services.bitcoin.ports contains an invalid type, it should be a number, or an object  
services.electrs.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

## LND logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor.ports contains an invalid type, it should be a number, or an object  
services.bitcoin.ports contains an invalid type, it should be a number, or an object  
services.electrs.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

## electrs logs

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:  
networks.default.ipam.config.subnet is invalid: should use the CIDR format  
services.tor.ports contains an invalid type, it should be a number, or an object  
services.bitcoin.ports contains an invalid type, it should be a number, or an object  
services.electrs.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports contains an invalid type, it should be a number, or an object  
services.nginx.ports contains an invalid type, it should be a number, or an object  
services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

## Tor logs

# ERROR: The Compose file ‘./docker-compose.yml’ is invalid because: networks.default.ipam.config.subnet is invalid: should use the CIDR format services.tor.ports contains an invalid type, it should be a number, or an object services.bitcoin.ports contains an invalid type, it should be a number, or an object services.electrs.ports contains an invalid type, it should be a number, or an object services.lnd.ports contains an invalid type, it should be a number, or an object services.lnd.ports contains an invalid type, it should be a number, or an object services.nginx.ports contains an invalid type, it should be a number, or an object services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

# ==== Result ====

The debug script did not automatically detect any issues with your Umbrel.

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 17, 2021, 5:06pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/12 "2021-11-17T17:06:00Z")

</div>

Start over.  
Fresh install from zero.  
Delete the SSD partition or maybe you should change that SSD drive.  
Do not format it in NTFS, only ext4 or just delete the partition, umbrel install will take care and create one in the process.

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 17, 2021, 5:07pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/13 "2021-11-17T17:07:22Z")

</div>

> [@DarthCoin](#):
>
> Fresh install from zero.

Thank you, I’m downloading fresh Umbrel 0.4.8 and will try to install it

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 17, 2021, 5:09pm UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/14 "2021-11-17T17:09:44Z")

</div>

Do you had funds in that node?  
[Here is a guide about restore funds](http://community.umbrel.com/t/how-to-restore-your-node-wallet/3602/)  
If you have funds in LN channels I would recommend the option 3. Easier and faster.

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 18, 2021, 12:44am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/15 "2021-11-18T00:44:19Z")

</div>

> [@DarthCoin](#):
>
> Do you had funds in that node?

Nope. Just testing before to send something there. Looks like super unstable yet =(

After upgrade to 0.4.8 I have another error:

> **Error: Failed to connect external drive**
> 
> There was an error connecting your external drive. Please consider using the recommended hardware listed on [getumbrel.com](http://getumbrel.com)

I hope I can’t killed my SSD by doing experiments with Umbrel

---

<div class="post-metadata">

**Author:** ![vmo](https://avatars.discourse-cdn.com/v4/letter/v/47e85d/32.png) [@vmo](https://community.umbrel.com/u/vmo)\
**Post date:** [November 18, 2021, 12:52am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/16 "2021-11-18T00:52:12Z")

</div>

> [@vmo](#):
>
> I hope I can’t killed my SSD by doing experiments with Umbrel

It’s weird because my linux laptop has seen no problems in SSD, successfully copying and reading data.

---

<div class="post-metadata">

**Author:** ![DarthCoin](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.umbrel.com/darthcoin/32/1628_2.png) [@DarthCoin](https://community.umbrel.com/u/DarthCoin)\
**Post date:** [November 18, 2021, 9:56am UTC](https://community.umbrel.com/t/booting-problem-system-service-failed/4687/17 "2021-11-18T09:56:46Z")

</div>

You know what we say… You are not a bitcoiner if you are not reckless 🙂
