Adventure in Umbrel Restoration

Update on Problem 1

I’ve created 2 new seeds, and tried to restore both multiple times. No success. I get the same error. Still have a missing seed. Something about what I am doing means that umbrel cannot restore from any 24 word seed.

Same thing happens when I type nonsense in for recovery words. I refuse to believe I am this bad at writing down words and typing them in again.

Seed imported in BW showed some old transactions so seed is ok. Thing is when you restore from channelbackup, channels are forceclosed and your funds are locked two weeks as I remember it right. Until this time you will not see funds returning to your onchain wallet.

That’s the only thing that gives me comfort here. But the data on BW seems incomplete, even before the recent channel closures. For example, the most recent transaction shows only the change retuned to the wallet, and doesn’t count the input utxo as part of the Wallet.

Yes, I have same feeling when imported umbrel seed in BW, some kind of incomplete data, but amount was right as shown in umbrel. At least you know your seed was written down right. I don’t know why umbrel is not able to recover seed. Hope you will get your funds back.

Hey all, I’ve figured out what is going on with problem 1.

Each time I spun up a new node, I was forced to use the “back” button at a certain point. This is because my computer was suggesting a password, and somehow was clearing the password field.

I would get past this by typing my password again, no biggie.

Well, it turns out the back button is kryptonite for seed restoration.

This was where I found someone reporting something similar.

Balance from force close is locked in limbo and will return to your on-chain wallet. If you have seed you are good. When did you do restore from SCB? 2021-07-30 05:41? If so, just wait.

This is one of your closing transaction.

There you can see lock time. I’m not sure how calculate exact maturity height from that number. If you would have correctly restored node, in you can run lncli pendingchannels. In list of channels there is block till maturity and maturity height. It is time when your funds will return. Default should be 2016 blocks = 14 days from force close. Hope this help and sorry for my English.

So, we just finished syncing, and it seems I am going to run into every issue I’ve come across researching how to restore my funds.

At the moment, we just got to full sync. Still 0 funds showing in the on-chain wallet.

In addition, when I try to generate an address, I am getting a blank address area. It looks like this.

I see potential solutions there. One involves the v3_onion file, which doesn’t seem to apply, as mine is of size 99.

I am a bit nervous about staring my user data all over again, considering I just got the restore to work, but that might be what I do tomorrow to see if a fresh scan can be done.

BTW. I am pretty certain my seed restore went well, as my public address for my lightning node is the same as it was before.

Is there any other way to force a rescan of wallet transactions with Umbrel? I found something relating to land -reset-wallet-transactions, but I can’t seem to figure out how to call this command via SSH.

Just tried the rescan options from this:

It doesn’t seem to have worked.

Still 0 balance.

one more note

When I look at the LND logs, it is only scanning for 31 addresses, which isn’t enough. I can tell because of what blue wallet is telling me. Any way to get LND to scan for more addresses when I do the -reset-wallet-transactions command?

I also though I would try the channel backup again, as there is still one more channel open. I figured maybe the node would see a new address closing. But I can’t do that, I get a 404 error in RTL. I think this tells me that LND is still messed up somehow. I am pretty close to wiping it once more.

Funds are Safu, mostly!

I have finally been able to get all of my on-chain funds displaying in the umbrel UI. The last set of issue I had related to having LND in a weird state of some kind (technical detail I obviously understand really well). So, I reset the user data one more time on the umbrel (without wiping the SSD). You can see (how to do this here.)[]

I deleted one of my comments about the funds being in state unreachable by my private keys after closing. It turns out that my node new how to get to these after restoring from seed and doing the channel backup procedure (even with an old channel state before the close).

This was a pretty nerve wracking event, but I have a lot of confidence in doing it again, as I sure learned a lot!

Thanks to everyone who reached out to help!


Oh, the reason I said “mostly Safu” is that there is one channel that is still unreachable, presumably because my peer is offline as well. Will keep pinging it to see if something shakes out, but for now, I’m happy with 90% of my funds!

Question from a non-programming noob to LN. (Programming an alias for my node was complicated!)

If my Umbrel node went down, would it be possible for me to restore my funds?

Is there a simple way to prevent the amount of effort you required to recover your funds?

This might be a LN deal breaker for me, as if it is beyond my capability to recover the funds, or there isnt a simple way to prevent node failure issues, then I’m not sure if its worth the risk.

1 Like

I think I got pretty unlucky. To boil down the issues I had:

My original hardware failures occurred from a loss of power, I am relatively sure. This kicked everything off.

Then, I ran into a bug with the back button thing. If I had been using a browser with a less aggressive password manager, recovering on-chain funds would have been a breeze. And it was as soon as I switched.

I am not sure about the last issue. I think I had another power loss while I had everything out and about in troubleshooting mode (someone pulled the plug). LND got in a bad state, which really required just another recovery.

At this stage, things are humming along. I learned that I need to make my setup more robust to these kinds of power disruptions though.

Hey fireworksurprise, I have read this thread with particular interest. “Recovering” is my number knowledge gap to make serious use of Umbrel and the suite of apps that go with it.

I need a Bitcoin Core Node that I can recover my funds to be “top security” before I can add it to Security model. Which I want to do.

fireworksurprise, is there a way that I can have you recount a “step by step” instruction that we might be able to use and point to, for the future in this Community Knowledge Base? A known working Recovery Procedure. .

I would also like to create a “teaching criteria” for this subject.

Thank you very much, Love ya baby. :slight_smile:
Niles Anders.

Hey @EscapeVelocity, really not sure that I am the “step-by-step” recovery guide kind of user. My knowledge of the subject is fair to good, but I am no expert.

Just about everything I did to get it working was found here.

The problem with troubleshooting tips like that is that there isn’t a context as to why each of those items may be the next thing you should try. In my case, I just had to trust that I had all of the data I needed to restore.

With comfort that this was the case, I just made edcuated guesses about what was going on and tried things.

Thanks for the update and github link! I’ve been trying to avoid starting from scratch (again) by running some commands in terminal, but it looks like I’m going to have to reset everything.

  1. did you have to re-flash your sd card?
  2. what browser were you using when your seed phrase was accepted?

thanks for the help!

For all those having problems with restoring dead Umbrel node and not only with that:

  • please read first the Guides section of this firum - many guides there
  • please, in order to start restore procedure, be sure it is the right thing to do, aka you already read an tries all procedures explained into detailed Umbrel troubleshooting manual
  • if you do not have another option than restore procedure, then please read first this guide how to restore your Umbrel node funds using 7 methods. I would encourage you to use method no.3, the easiest for noobs, fastest and safe, tested. Also is offering a good companion later for your new Umbrel node (as explained here).
    Start fresh with a new instance of Umbrel node, new wallet, new nodeID, is the best way and no more complications.